Make2D Issues Rhino 8

Hello, I previously tried using section tools but my files completely crashed the computer so I have gone back to clipping planes that worked once before. I keep making this section in 2 point with a clipping plane but when I go to Make2D it only has weird not even clipping intersection lines. This worked 30 minutes ago with a different section but now it is not working. Here are some pictures of what I am doing and the end result. Please help my project is due Friday! The first is the end result and the last three are the sequence.

Hi Luiza -

Please post the output of the Rhino SystemInfo command and a 3dm file that you are having problems with. If the file is too big or contains information that shouldn’t be public, you can upload it from Rhino - Upload to Support. Make sure to copy a link to this topic into the comments field on that page if you choose to use that.

Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Educational Lab License, build 2024-03-12
License details: LAN Zoo Network Node

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.17

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro K1200 (NVidia) Memory: 4GB, Driver date: 2-7-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.52
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-7-2024
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

I just submittted it. I want to make a section perspective from view 4. Thank you for your help!

Hi Luiza -

Please change the update frequency in the Rhino Options to release candidates and let that find and download 8.7. A lot is getting fixed in each release candidate, so, when you’re having problems, it’s best to try the newest available.

I ran Make2D on View4 here, and that seemed to work, but it’s a large scene and I might not be looking at the correct place. There are a few bad objects in the file, and running SelBadObjects will light up quite a bit at the center. Not sure if this is causing something you’re seeing.

Here’s what I got.
Make2D of (4.6 MB)

I will do that yes, this is just a school computer so I always have to request the faculty to update it and that takes at least 2 days. Thank you for your help! Have a nice day!

Hello, I did the SelBadobject for a different type of cut and it is still giving me the same issues: making a completely unrelated Make2d.

I have requested to have admin update it but I fear they will only get back to me on Tuesday. Is there anything else I can do in the mean time to get this to work?

Hi Luiza -
I now tried this on Rhino 8.5 on my Mac, and that seems to be working as well.

“Completely unrelated” makes me wonder…

Taking a closer look at your photos, I see the following:

This dialog is on top of a viewport that very clearly is not the “Right” view of the model. It’s possible to wrestle a “Right” view in a viewport into a perspective view but when I open the model that you sent, there’s a single, maximized, viewport called “view4”. When I run MaxViewport to show all viewports, there are 3 viewports: “view4”, “Rightonepoint3”, and another “view4”.

This means that, when I open your model, and run Make2D, it’s impossible for me to get that dialog to say “Right” in the View dropdown. Your version of the project is thus slightly different than what I got.

You have taken pictures of your screen with your mobile phone, making it a lot harder to see what’s going on. Please use the Print Scrn button on your keyboard to copy the screen to the clipboard. Alternatively, you can simply use Ctrl+C with an active Rhino viewport to put a picture of that viewport on the clipboard. There’s also the Windows “Snip” tool that you can access with Windows+Shift+S to make a screengrab of a selection of the screen.

At any rate, I see that you are running two monitors. It’s possible (but impossible to tell from the pictures you have provided) that a viewport is active on the other screen that shows something else than what the viewport under the Make2D dialog is showing. Make sure that the correct viewport is active when you run the command, or make sure to select the correct view from the dropdown in the dialog.

[Also note that the recommended amount of VRAM per monitor is 4 GB, and you are running a rather demanding scene on two monitors on 4 GB]