Rhino 8 Mac Cmd + Shift + Right Mouse Button highlights surface or edge

I have a UI annoyance but it’s probably not a bug:
In Rhino7, I could CMD+SHIFT+RMB click to rotate view from wherever I clicked. It was very helpful mid-stream when modeling, or making difficult selections (i.e. chain selecting rails in a sweep). In Rhino8, I can do the same thing however now it also highlights whatever I click on and keeps that highlighted as I rotate the view. On paper, this feature probably seems like a great idea because CMD+SHIFT+RMB is also used to simply select sub-objects (like the ones that get highlighted) so it gives you a preview of what you’re about to select. However since the same key strokes and mouse button is used for the incredibly useful “rotate about a point” command (which is immensely useful) the highlighting effect is extremely distracting and can actually interfere with being able to see what you want while rotating.

I’m not sure if anyone else has noticed this, or find it as distracting as I do, but does anyone know of a way to turn-off this auto-highlighting effect?


Hello- you can turn off mouse over highlight

Settings > Advanced:


However, the cmd-shift for view tumbling should only be needed if the view is a parallel projection and plan to the CPlane (by default) . Once the view is skewed, plain rmb-drag ought to be enough.


Thanks Pascal, I will give that setting a try! – EDIT: That worked! Great thanks!

One thing I’ve noticed is that as I model and zoom in and out from small detail to large overall volume, over time, Rhino seems to lose where it’s “centered” and I often have to CMD+SHIFT+RMB to rotate in an expected manner. Maybe with Rhino8 this has been solved? Rhino7 seemed to act this way for me. I always use “Perspective” from the drop down, which I believe is not a parallel projection?

Hello- Zoom Target (RMB of the Zoom Window button) is verty helpful in resetting the camera.


1 Like