New mouse bug?

This has happened 3 times since I downloaded the latest WIP. I’m working in Rhino in a perspective viewport, as is my wont, and suddenly my RMB becomes Zoom instead of Rotate, and I can’t select objects in the viewport or change it to anything else. And, Shift+RMB becomes Rotate and CTRL+RMB becomes Pan. In order to fix it, I have to close & restart Rhino.

Steps to repeat this:
In a perspective viewport, hold down the RMB. While holding it down, momentarily press shift + ctrl simulataneously. Release RMB and click-hold it down again, and it will no longer rotate the view.

EDIT: this is NOT the problem I’m seeing, actually.

Click again shift + ctrl + RMB

I’ve run into this quite a bit and the cure is as Inju posted to press ctrl shift again.
But I don’t recall in this being a problem like it currently is I wonder why this is happening more often now.

Seems like a bug or change in Rhino behavior. For users who don’t figure out the cure since it’s cryptic are stuck wondering and may close and have to reopen rhino to get rid of it only to run into it again. I was the first few times this happened. I think it should be looked at.

That’s not the same issue at all. This issue is new - I’ve never encountered it before this latest WIP.

You didn’t understand me, I mean, it’s not a problem, it’s how they write
“to be two camps and no way to make the existing settings make both happy”.
It’s a “mistake” I like, and it’s always been.
Example Rhino 7 WIP:

Example Rhino 6:

I see. Actually the problem I have had is not quite the same. My view gets ‘stuck’ in a non-parallel view. I think my ‘steps to repeat’ are not correct, because as you mentioned, this switches to a parallel plan view. I’ll create a new thread when I figure it out.