Rhino 8 installation program went amok

I have upgraded Rhino 7 license to Rhino 8. I have bought very powerful ThinkPad P16 Gen 2 laptop and I installed Rhino 8 on it. (To my surprise, I had to remove Rhino 7 from my old laptop.) Two weeks later motherboard of the new laptop failed and was replaced under warranty. Microsoft BitLocker drive encryption blocked my access to the SSDs, so I had to wipe out the SSDs and to install Windows 11 again. The Windows 11 forced me to choose name of the new laptop. The old name was H****. I changed it to T********. When I tried to install Rhino 8, the installation program said that it could not install Rhino because my computer had wrong name. I used the operating system to change the name to the old name (H****). It did not help. Every time I try to install Rhino 8, the installation program displays small window with error message “Validation Failed” and says that Rhino 8 license cannot be used on a computer named H****. When I click close button in the window, Rhino 8 starts and displays message: Your license validation grace period has expired… etc. When I run Options>licenses in Rhino 8, it says that I have have standalone license and it displays its serial number. When I quit Rhino 8, it sometimes crashes and leaves dump file on the desktop. I have latest dump file (RhinoCrashDump.dmp) but discourse.mcneel.com does not allow me to post it here.

If your computer dies and you have a standalone locked license on the machine you’ll need to contact sales and have them release the validation. One of the benefits of the hosting the license on your Rhino account is that can never happen.

Do you mean the salesman who sold me the license?

The contact link i posted above should suffice.

Your link is not related to sales.

I tried to send email to sales@mcneel.com. I received the following error message:

When I send emails from the same address to other addresses, there are no error messages.

I can confirm we did a message from your gmail. The error you are seeing is from the Email client you are using.

We cleared out the validation, please try to add again.