Rhino 8 for mac on a M1 Max --- having serious issues

Hi, I would like to know how many other users of Rhino8 for mac experience problems.
I am using a Macbook Pro M1 Max - 64 Gb / 4Tb - OS 14.4.1 - 2022. Running the latest update of Rhino 8.
I have waited for Rhino 8 to come out before buying a new Mac for the reason it would be working without issues on the Mac OS silicon platform. (Metal)

However I seem to be running into issues.

Earlier I had some crashing issues with a file that was 1.6Gb …I managed to reduce the file to 1Gb and it seemed better.
Then new issues appeared. Initially when these issues occurred I thought I solved it with re-installing Rhino 8, but issues have returned.

  • an object drawn as a solid, changed into seperate open surfaces.
  • I can not snap to these (and other) surfaces. it snaps to a far distant undefined point. ??
  • clicking on surfaces highlights arrows from the edges to inside of that surface.???
  • I also can not delete certain surfaces…
  • This happens now on multiple files.
  • autosave is frequently and it takes about 30 sec to save, which is annoying.

I have purged, without result
No bad objects
Rebooting macbook doesnt help.
Re-install Rhino 8 doesnt help.

I tried to move back to Rhino 7 on an older mac mini with intel processor 3GHz-6core, 64 Gb, Catalina OS 10.15.7, exported the RH8 file to RH7 .

Then the file is fine, I do not have the problems that I have on RH8 on the M1 macbook pro M1 Max, however the file is a lot slower than in R8.

Are there any known issues with Rhino 8 for mac when it is installed on a M1 macbook? (64Gb Ram).
Is Metal not doiing its job?
Do you advise to move away from mac and buy a dedicated windows computer? Is Rhino still not usable on a Mac?
I would really like genuine advise wether this is a ongoing Rhino issue, a Mac issue or that it is a fixable issue? I desperately need to finish some jobs and this is holding me back big time…

Hi Hans,

I’m running an M1 on 13.5.2, if i reproduce the issue i’ll get a bug report started.

Can you zip and upload your file here with a link to this post? Rhino - Upload to Support

I’ll need steps to reproduce as well. Thanks

Japhy, I think my problem was more related to the fact that I had ‘Project’ ticked on in the filters on the left. I think I am good at the moment. Thx for reaching out.
Sorry to think it was a glitch in Rh8 for Mac.

Can you still confirm that Rhino 8 should run without problems on the M1 Max??

For the most part, The M1’s + are the preferred chipset. Rhino 8 does have it complexities, particularly in compatibility with older plugins.

If you run into any problems please reach out and we’ll address it.