Rhino 8 bug: UV get lost by OBJ export/import


very important for data exchange is to keep UV. Often in the past I exported&reimported meshes as OBJ to burn in the UV to the mesh. Later, this meshes are good for example for FBX export. At Rhino 7 it was quite ok working, but now it’s not working anymore. Please fix it.


before export

and here after export and import:

UV destroyed by OBJ export.3dm (6.5 MB)

Hi Micha - I think you are correct. I’ve just noticed this myself with an *fbx export and reported it as a bug.

This really needs to get sorted as a matter of urgency as file exports with UV maps is critical to anyone using data exports to other render packages.


1 Like

I thought 3ds can be used as workaround, but it’s not working, the UV get reset and not kept. Do you have an idea for a workaround if also Rhino 6 and 7 fails? Some objects lost the UV in every Rhino version.

I’ve tried exporting / importing from RHV8 to Keyshot & Unreal Engine with the same bug.

I’ve even tried a number of old RHV7 files and even created some new test files in RHV8 unfortunately with the same result.

I thought that I must have missed something that could be new in the way UV maps are applied in RHV8 but unfortunately it looks to me like a Bug with RHV8.

Hi Micha - on that file, a ‘round trip’ via OBJ seems to have the same results in V7 and V8, here - no tcs, or, all 0,0 . If I make a new mesh in v8 and edit the texture UVs and export to OBJ it seems to work as expected… still testing.


Thanks Pascal - Interestingly I created something new in V8, applied a box UV map and exported as *fbx and re-imported back into V8 and the UV maps were lost? I also imported that new V8 *fbx file into Keyshot / Thwinmotion / Unreal and all lost the UV maps.

Here a part of my current project which fails always in every Rhino version.

Export OBJ UV destroyed always.3dm (6.3 MB)

Here I create a fresh mesh sphere in Rhino 8 … after export->import I get no UV anymore.

1 Like

Unfortunately I get the same result - I’ve tried loads of things / settings / software programmes and no luck

Hi Micha - I do have a more recent build - I do not see what you show there, I’ll try the released 8.0
That said, in your chair model, tcs are set to 0,0 from V7 and from V8.
(From what I can see, Quad style mesh spheres do not get tcs at all, as created, in 8.0.
RH-78505 MeshSphere and texture coordinates)

@Micha @magnatizerr here is a sphere with mapping applied, and edited, and exported to obj - does this work?
quadmapped8.obj (27.3 KB)


Pascal - From doing a number of tests here, it seems that anything I’ve created in RHV7 and then opened in RHV8 and then exported as an *fbx, the UV maps are not exported / lost. Even if they show up in the RHV8 file as bring correct before export.

Hi All,
Is this not related?

What I found is that no pbr materials were exported using FBX format, if I used a simple non pbr material FBX worked. I think it’s something to do with programming or the Rhino sdk.

Here is the link to the thread and Nathan never answered concerning the FBX materials problem I am running into.

Rhino live link to Blender? - Rhino / Rhino for Windows - McNeel Forum


Hello Sir. I have fixed with my app WeCov3r Studio. Please have a look.

UV undestroyed by OBJ with WeCov3r.obj (1.0 MB)
The longest time is writing the message! I’m considering doing GRASSHOPPER coding. Would you be interested? Anyway, you can use my 3D to 2D SaaS webapp and its free version.

Result in a nutshell!

Thanks for pointing me to this page. Looks interesting. But since I have a good unwrapper, I’d like to see Rhino keep the UV for OBJ/FBX only.

1 Like

Many thanks WeCov3r and I for one will definitely have a look at the program but this is would be a work around and doesn’t fundamentally fix what I consider is a BUG in RHV8. The additional steps needed to completely unwrap and texture every item will add a considerable amount of time to my workflow where I would have normally have just applied a simple ‘box’ UV to an object.

Essentially UV maps used to work in RHv7 but now doesn’t work in RHV8 so I really need to get this resolved before I can start using RHV8 for working projects.

Going outside/inside Rhino is cumbersome, I agree. Though, I made this sphere as well, please check this out, this is the exact flattening

sphereUV.obj (15.2 KB)

What is the unwrapper you are using I’m guessing some external sofware with Grasshopper?