Rhino 8 Beta - Viewport Stutters with Turntable

Hello All

System Info

Rhino 8 SR0 2023-9-28 (Rhino 8 BETA, 8.0.23271.13233, Git hash:master @ 4acd4a788d5f9e7999c3d49c07cdd2f60038b920)
License type: Commercial, build 2023-09-28
License details: Cloud Zoo
Expires on: 2023-11-12

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 32Gb)
.NET Framework 4.8.9181.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 7-11-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port 1
- Secondary monitor attached to adapter port #2
Primary OpenGL: NVIDIA RTX A1000 Laptop GPU (NVidia) Memory: 4GB, Driver date: 5-30-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 529.08
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-30-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23271.13233
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

I noticed this issue generally with my spacemouse thinking it was a driver issue, but now it looks more evident that there is something you need to look into.

1- Start with empty file
2- Create a box
3- Run Turntable with a value of 14

some stuttering will happen especially with the mouse movement.

See video below

Update : Resetting Rhino Options and Removing third party plugins solved the issue.
my job now is to find the bad guy.

Update 2
Re-imported Rhino Options Brought back the issue.

Update 3
It is the Cursor Tooltips.

“Rhino.Options.CursorToolTip.CommandPromptPane” Solved the issue.
Thank you for Reading

1 Like

Interesting; @jeff maybe we should temporarily disable cursor tooltips while turntable is active. What do you think?

1 Like

It can be a good solution. I just disabled it altogether since it affects the smoothness of my Spacemouse as well.