Rhino 8 Beta - Clipping Drawing Bug

Hey All,

Been playing around with the Rhino 8 Beta and have noticed an issue with the Clipping Section and Clipping Drawing connection. I can create the clipping drawing just fine, but when the clipped geometry changes (or when the clipping section is deleted), the drawing fails to update. I’ve tried to reset the section but nothing changes.

do you have history enabled?

Hi Caleb -

I’m not sure what you mean by resetting a section. Did you try the UpdateClippingDrawings command to force the update?
If that doesn’t work, please post a simple 3dm file that shows the behavior you’re running into.

I do not. It’s interesting, even after the clipping section the drawing references is deleted (and Rhino is restarted), the drawing still populates

Error_Example.3dm (8.3 MB)
Hi Wim,

Here’s that file. I’ve tried UpdateClippingDrawings with no luck. The drawings shown in the prior screen shot exist even after their corresponding ClippingSection is deleted.

I was able to recreate the error in these screen shots. I can create a clipping drawing just fine, but it seems like the link between the two breaks. Updating the section or deleting it has no impact on the drawing.

I downloaded your file. It does not have any clipping planes. Can you share the steps of commands you used to create the clipping sections and drawings, then what you did to modify/update?

Also, is it possible that you used “NestedClippingDrawing” instead of “ClippingDrawings” command to create the drawings?
The difference between the 2 is that “NestedClippingDrawing” extracts a static copy of the sections drawings only (no background, to use in fabrication, etc.) and it does not update with model or clipping plane changes. Drawings are output to the current layer.
“ClippingDrawings” command, creates dynamic drawings that update automatically when you move the clipping plane, and can also update with model changes using “UpdateClippingDrawings” command. It organizes the output of sections and background geometry in locked layers using the section name.

Rhino Beta 8
Version: (8.0.23278.13003, 2023-10-05)

ClippingDrawing bug/limitation/issue what ever it might be called.

  1. Make a new drawing with some geometry (4 views, top, front etc.) in top view
  2. Make a clipping plane in front view in middle of geometry
  3. Switch clipping plane ON in front view to verify what You should see
  4. Make a ClippingDrawing in top view You should see the same as in front view
  5. Move clipping plane up in top view such that it does not clip the geometry anymore.
  6. The ClippingDrawing should be empty but the previous geometry is still there.

So it looks like when a ClippingPlane return no geometry to ClippingDrawing
it choose to do nothing.

Did 5. again and deleted the ClippingPlane, that worked ONCE, ClippingDrawing
geometry where deleted! Next time I tried it did not! Please take a good look
into this this ClippingDrawing feature it’s a bit unreliable so far. IMO

Hei Odd -

I’m currently running an internal build - (8.1.23282.18001, 2023-10-09) - and am not seeing this issue here.


It looks like this might have been fixed in the meanwhile. I’m not immediately finding a YT item that handles this, and, thus, I’m not sure if the fix went into 8.0 or 8.1.

A new public Beta should be released tonight and you could check that one in the morning. If you have a simple 3dm model, I can take a look here.

Hi Wim!

Sorry but the version below still got “clipping drawing show nothing bug”

BETA (8.0.23286.1003, 2023-10.13)

See attached Zip file with 4 files

Rh8B_ClippingDrawing_Step1, 2, 3.jpg


Not a big problem but it might confuse …

Maybe a text warning “Shows nothing”

Best regards,

Odd H.

Den 2023-10-10 14:53 skreiv Wim Dekeyser via McNeel Forum:

Rh8B_ClippingDrawing_Show_nothing_bug.zip (949 KB)

Another problem with Clipping Drawing
Rhino 8 BETA (8.0.23286.1003, 2023-10.13)

If You delete a Clipping plane with a clipping drawing and then do undo,
the undo isn’t complete. Some of the layers (may be) missing!

I’ve not investigated deep into this but a failed Undo is critical IMO

See attached Zip file with example .3dm file (original step 1)
Step 2 delete
Step 3 undo

Rh8B_ClippingDrawing_Delete_and_Undo_bug.zip (991.0 KB)