Rhino 7 won't launch on Windows 11

Hi, I’m having some troubles launching my Rhino program that’s been downloaded directly from the Mcneel website. I have tried using the shortcut, file location, apps folder to launch the program but it wouldn’t launch until at least 15 tries later. I’ve checked task manager to look at the progress of launch but it usually stops at 34MB.

Is there a way to fix this? I believe I have messed around with the Host Editor and that is what causing this problem, how can I fix the host back to default? Thanks!

It’s really hard to diagnose without seeing system information.
1- Have you tried to do a fresh install?
2- Can you right click on Rhino icon and select “Run as Administrator”
3- once you are in rhino please type “Systeminfo” and paste your information here.

I was using a copy of the software from my friend and have just removed it, now the fresh install would not work at all. I’ve tried to run as administrator but it still doesn’t launch. When I try to open the file location, it’s still dated to when I installed the copy from my friend and not a new file, though I have already uninstalled the software… How do I get rid of the old ones completely and let it run fresh?

go to apps and features, select rhino and click on uninstall, If your friend gave you a cracked version, some of that my stay in your machine and may require you to manually delete these files, since they may cause a major harm to your machine.

I have already uninstalled the software and redownloaded a couple times… Any tips on what files I should be deleting? I’ve already tried to delete most files that I can find. Also, how do I reset the host to default settings?

I’ve seen this a couple times lately, update or try repairing your .Net install, then install Rhino as Admin.
https://learn.microsoft.com/en-US/cpp/windows/latest-supported-vc-redist?view=msvc-170

I’ve tried doing that by right clicking the downloaded software and through Rhino installer, modified and repaired but it still doesn’t work. Is there a way to repair the .Net install manually?

Hi Germaine -
Have you gone through these steps:

-wim

I have updated my windows 11, it is totally up to date. I am trying to open Rhino 7 but just the launch page pops up for a couple of seconds and then vanish. I am only able to open Rhino 7 in Safe Mode.
However it doesn’t include very basic and necessary features of Rhino, which are frequently used. This is making it difficult for me to learn the software.
I request you to please help me solve this issue.

With Rhino open in safe mode, please run the SystemInfo command and copy/paste the results here.

Rhino 7 SR32 2023-8-9 (Rhino 7, 7.32.23221.10241, Git hash:master@ 3d9c816c4cd57561d12d8f53246bce304f314ba2) License type: Evaluation, build 2023-08-09

License details: Cloud Zoo Expires on: 2023-11-29

Windows 11 (10.0.22621 SR6.0) or greater (Physical RAM: 156b)

Computer platform: LAPTOP Plugged in [80% battery remaining]

Non-hybrid graphics configuration.

Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 11-30-2021 (M-D-Y). OpenGL Ver: (null) > Integrated accelerated graphics device with 3 adapter port(s) Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings

Safe mode: On

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On Graphics level being used: OpenGL (null) (primary GPU’s maximum)

Anti-alias mode: 4x

Mip Map Filtering: Linear Anisotropic Filtering Mode: High

Vendor Name: Unknown

Render version: (null)

Shading Language: (null)

Driver version: 31.0.15.3168

Driver Date: 4-13-2023 Maximum Texture size: n/a Maximum Viewport size: 256 x 16843008

Z-Buffer depth: n/a

Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino C:\Program Files\Rhino 7\Plug-ins\commands.rhp

“Toolbars”

7.32.23221.10241

7.32.23221.10241 C:\Program Files\Rhino 7\Plugins\rdk.rhp “Renderer Development Kit” C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp

“Commands”

Please see if you can update your drivers for the video card, that would be the first thing to try.