Rhino 7 WIP: SubD export to .obj: map Z to Y

Just noticed that exporting a subd to a .obj file with “Map Rhino Z to OBJ Y” selected doesn’t actually map z to y on the subd.

e.g subd cylinder and a copy converted to nurbs on the left, export to obj and re-import (right 2 objects) shows original subd cyl rotated


do you have the anti z to y checked on the import settings? export mapping x to y working here-

the data written into the obj appears to be incorrect for the subd - here’s the .obj loaded into 3dcoat - both objects were upright in Rhino

here’s a more practical example: model has 2 subd surfaces and a bunch of nurbs - export to obj with map-z-to-obj-y selected. Obj looks like this in other apps:

convert the subd’s to nurbs - then export - the obj looks correct:

obviously the workaround is to not map z-to-y and reorient in the other app - or convert to nurbs before exporting.

I’ll look at this tomorrow. We get the meshes in a different way for SubDs. For other objects we pass a transform to the mesher and the output is transformed appropriately. With SubDs, since you have the option of surface or control net, it does not go through the mesher. I probably forgot to apply the transform.


See https://mcneel.myjetbrains.com/youtrack/issue/RH-55831 to check on progress.

RH-55831 is fixed in the latest WIP

Thanks for the quick fix.