Rhino 7 Shut down my computer

I was playing with the shadow settings in a rendered mode. and it keept restarting my computer. and the latest time it reset Rhino 7 back to factory settings, which deleted all my custom dusplay modes.

this is the system im running.

Rhino 7 SR19 2022-5-17 (Rhino 7, 7.19.22137.07001, Git hash:master @ 3ae9a3803ff1583b53c0ef27b6860e06ef2d363a)
License type: Commercial, build 2022-05-17
License details: Cloud Zoo

Windows 10 (10.0.19043 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 5-4-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.77
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-4-2022
Driver Version: 30.0.15.1277
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

it is virtually impossible for user mode code like rhino to crash a machine – it can appear to do so by asking the OS or display driver to do something which triggers a bug in those components, or which uncovers marginal or bad hardware (memory, drive, etc), and so forth

so, assuming this is repeatable, I’d start by simplifying the scenario, first by using just one display, then unplugging other unnecessary peripherals, checking for interesting system log entries in event viewer, running SFC /scannow, checking memory, checking for bios updates (or whether your current bios version has known issues), checking connections generally in the machine, and such, to see if you can narrow down what is causing this behavior

can you look into the WHEA logger in the event viewer? it is like related to hardware instability.? do you have any sort of CPU / Memory or GPU overclock?

Another issue is probably overheating in your system, can you install HWinfo and take a look at the thermals.

This is my event viewer log.

Im not sure what any of it means.

this current tempretures, whith rhino running

And this is what my cpu is cloking

I’m not sure what it is supposed to be doing, so any help would be appreciated

in the event viewer: right click on Event Viewer (Local)

image

image

call it my WHEA and this should show the errors associated.

Yup… It is core 5 on your CPU (Thread #11)
Core # = Floor (APIC/2)
do you have overclocking on your CPU? do you have an updated BIOS?
Also Are you Running SLI? that’s probably another suspect.

Post the complete SystemInfo results including PlugIn info.

Rhino 7 SR19 2022-5-17 (Rhino 7, 7.19.22137.07001, Git hash:master @ 3ae9a3803ff1583b53c0ef27b6860e06ef2d363a)
License type: Commercial, build 2022-05-17
License details: Cloud Zoo

Windows 10 (10.0.19043 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 5-4-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.77
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-4-2022
Driver Version: 30.0.15.1277
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino
C:\Users\patri\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.11-beta\Substance.Win.rhp “SubstanceImporter” 2.0.11.0
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\patri\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Crayon (43f0446f-00a7-4ff3-864f-0d3af5e47e2b)\1.0.7750.23916\Crayon.rhp “Crayon” 1.0.0.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.19.22137.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.19.22137.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.19.22137.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.19.22137.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.19.22137.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\NamedPositions.rhp “Named Position”

From what can gather my CPU can overclock and I’m not running SLI (as my mother board doesn’t support) update my bios may be out of my capabilities

Are the shadow settings in one of the “Rhino plugins that do not ship with Rhino”?

If the answer is no disable all the plugins that do not ship with Rhino and reload Rhino. Then test if the problem still occurs. If the problem does not occur then enable one plugin at a time and restart Rhino and test until the problem occurs again.

If the answer is yes disable all the plugins that do not ship with Rhino except the one where the shadow settings are entered and restart Rhino. The test if the problem still occurs. If the problem does not occur then enable one plugin at a time and restart Rhino and test until the problem occurs again.

Apologies, I’m not sure how to tell if the shadow settings are in a non rhino plug in.

I was just adjusting the settings in the properties under display modes.

Hi Patrick -

Just disable all non-default plug-ins and start with that.
-wim

I disabled all plug in that does not ship with rhino, and reinstalled rhino and the problem continued.

I also must say the model I’m working on has a considerable large mesh in it. starting think that is causing it.

Hi Patrick -

On paper, your system looks like it should be able to handle pretty much anything, so my money is on this being a hardware issue.

Then again, if this is very file-specific on your system, please upload your file and typical steps to reproduce this. You mentioned playing with shadow settings. Are there other things that cause the system to shut down, or is it very specific to exactly doing that?
-wim