Rhino 7 shading not smooth, because of bad normals?

Hi devs,

I’ve modelled a ramp: ramp.3dm (239.5 KB)

The shading isn’t smooth in the rendered viewport for the nurbs, and mesh model, e.g. compared to blender.

I suppose the normals could be calculated better.

Can someone take a look?



that outer edge does not look very smooth. i would use sweep2 to create the surface (both straight lines as rails / smooth curve as cross-section curve). and then extrude surface as a solid.

1 Like

Assigned to Rhino category.

1 Like

Hi Michael - it looks like lighting comes into play - the ambient/skylight seems to be what is showing the facets in Rhino. If the render mesh settings ask for more initial quads, that also avoids the long skinny triangles that tend to show because, I assume, the normals are spread over such a long distance.


1 Like

Hi Pascal,

you are right. I have to think about it more, sorry.

Thanks (also Hessel and John)