Rhino 7 SelectionFilter Toolbar pop-up

Hi there,

I have an issue with the SelectionFilter whilst Working with Sub-D.

In my experience, it is very inconvenient having to check and uncheck the diffent selection options when moving and adjusting the model arround, it interrupts the thought process and general workflow. This is why in most cases I prefer to select holding shift+ctrl.

The Problem I´m having is that following certain commands (like Stitch or Slide) the SelectionFilter toolbar will pop-up unwanted, and since the quick selection with Shift+ctrl gets overridden by it, I have to stop and click it away in order to continue… This breaks my workflow since it could happen many times in the span of a few minutes and is extremely annoying.

Leaving the toolbar open or integrated in the workspace overrides the quick selection even if “disabled” is checked.

I have tried to find a setting to disable it, unsuccessfully.

And so I´m begging you for a possible solution! Maybe I have just overseen a setting or maybe some of you know of a workarround for this issue.

Thank you in advance for the time taken, in case you reply to this.

Have a good day.

1 Like

Hello - I believe what you see not a selection filter but a ‘choose one object out of a list of possibilities’ menu. Where you click could mean you want an one edge, or perhaps another edge very close by, or the face - Rhino needs to know which one you want. Ctrl-Shift does not filter any further than ‘sub-object’.

Is that the thing you are asking about? You can filter further with the selction filter buttons at the right end of the SubD Tools toolbar.


Hello Pascal, thanx for the reply.

In that sense the “list of possibilities” toggles what is selectable in the construction, which is useful for example if I want to drag-select a bunch of vertices. Which is why I called it SelectionFilter.

With Crtl-Shift I can select verices, faces, edges, double click to select the whole or a portion of a loop eather of faces, vertices or edges and any combination of the above. This makes it much more suitable for shaping in Sub-D with the Gumball.

Now as an example, when I Ctrl-Shift Click/Select one ore more vertices, and give the command “Slide” to shift its position along an edge, the “List of possibilities” pops up automatically restraining my further selections to vertices. This not only takes away sreen space (I´m working on a 15" Workstation laptop atm.) but also interrupts my workflow by having me to go and close it every single time.

Like I sad, I only need to restrict my selection when window-dragging the cursor, and the options given in the Sub-D toolbar are sufficient for that.

This is why I´m looking for a way to make it stop popping up all the time. And a way to do that was my ask.


Hi Riccardo - I’ve been running Slide and not getting any selection pop up at all… can you take a screen shot of the pop up thing you don’t like?

  • Pascal

Sure! Here you are.


Thanks, I-I-I got it now… you have this thing closed, and when you click on the filter buttons in the regular toolbar, it pops up because you cannot have filters active when this box is not visible - that is by design to avoid the inevitable confusion that would arise if users forget they have filters active and find they cannot select things.

So no, there is not a way to turn that off that I know of. I leave mine open and docked to the side of the command area.

(But I still cannot get it to pop up if I do not click a filter button - Slide, on its own seems not to force it open - are you clicking on one of the filtering buttons? )

There is still something missing for me…


I´m not clicking any of the filtering buttons.

Try this, remove/close the extended filter selection toolbar (the one I showed in the snapshot) from your work-enviroment. Once its gone, you will be able to crtl-shift click any of the features of a sub-d object and manipulate them with gumball (so, say a vertex from a sub-d sphere). Now crtl-shift click a given vertex to make it active and run the slide command.

If it´s not a problem just related to my Rhino, the extended selection filter toolbar will pop up.


Hi Riccardo - not happening… Slide just runs on the pre-selected vertices or edges. (except it does not always actually do anything on a single preselected vertex, here it just kind of pretends if the selected verts are too far away from one another, different question ) No sign of the Filters box at all. Do you have any plug-ins ? Can you run SystemInfo in Rhino and copy/paste the results here?


Hi Pascal, Riccardo means that


Thank you so much Pascal for taking the time to assist me with this, I really do appreciate it!
As you can see in file, the only plug-in I have is v-ray atm.

riccardo_systeminfo.txt (2.8 KB)

Yeah, that is what I understand but do not see - can you please shift-rmb on the Slide button that you are clicking and tell me what the macro is in there?


Hello Eddi,

Thank you so much, that is exactly what I mean! And sadly when that toolbar is visible/active ctrl-shift selection seems to be constrained by it and doesn´t work, even if everything is unchecked… which is why I don´t keep it as a sidebar.


@pascal … ! _Slide

Riccardo but there is still no benefit from activating filter and using CTRL+ALT at the same time.
_SelectionFilterNone and nothing pop’sup

Oi… I see now - if filters are set but the box is closed, this happens - thanks y’all. I do believe this is all as it should be and just make sure there are no filters set in the box.


Eddi and Pascal,

I will make myself a custom button for _SelectionFilterNone
Not the smoothest solution but one I can work with.

Tank you both again!


Hi Riccardo - that button exists in the set I showed up above a few posts - second from the right.


1 Like