Rhino 7 Render, Material Colors are overridden by Layer Color

Hello,

I recently updated my Rhino 6 to 7 and have been having problems with the material settings and render mode ever since. The default and custom materials that have WHITE color settings are overridden to BLACK whenever I open a file.

Whenever I needed to render in Enscape, I have been manually changing everything back to white, but when I save the file and reopen the next day, the colors are back to black again. I have tried to reset the materials to the rhino default, but whenever I restart Rhino, it’s back to a black custom color setting that I never created.

It seems like my Layer Colors are overriding my material colors because for example, pink layer object with white material color becomes pink whenever I restart Rhino. Is there a way to change it so that doesn’t happen?


Hello - is this the case if Rhino render is the current renderer?

-Pascal

Yes, Rhino Render as well. It’s like this for all my files, not just this model.

Hello- can you please run the SystemInfo command in Rhino and copy/paste the results here?

-Pascal

Hello,
Yes, it’s pasted below. (In addition, when I change the material type to Enscape and change the settings there, it saves correctly. It’s only when the material type settings are in Rhino)

Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05001, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Commercial, build 2021-06-09
License details: LAN Zoo Network Node

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP (Hosting Remote Desktop session)

Standard graphics configuration.
Primary display: Microsoft Remote Display Adapter (Microsoft) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).
> Remote Desktop display device with 16 connection(s)
- Windows Main Display using connection #0
Primary OpenGL: NVIDIA Quadro K2200 (NVidia) Memory: 4GB, Driver date: 6-21-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.48
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2020
Driver Version: 27.21.14.5148
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\naL\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21148.1551

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello- I do not know how remote desktop figures into all of this, but a test would be to disable Enscape in Options > Plug-ins page, close and restart Rhino - set material colors as you like them and then close and reopen the file - does it stay put?

-Pascal

Hi,
It happens when I am not remote as well. I’ve tried restoring Rhino to default, including disabling Enscape, closing, restarting and it’s the same problems with the wrong material colors.

Hello- can you please try with a brand new file, please use the No Template setting in starting the new file - make a couple of boxes or something, and set up materials, and see if that sticks?

-Pascal

Hi Pascal,
I made a test file and the materials stuck.

Is the problem in the file itself? Because it’s multiple files that I’ve worked on and saved that have the problem, but when I open files that my coworkers have created, the materials are all correct.

Also, when they open the files that I am having issues with, it renders correctly. Thanks

Hi Nat - do your co-workers also have Enscape?

Can you run Audit3dmFile on a (preferably small) file that does not work right, and on the test file and send me the text from each of those, or, post the files here or send them to tech@mcneel.com, with a link from this topic in your comments…

-Pascal

Hi Pascal, Yes, they all use Enscape. I will send the file to the email address. Thank you.