Materials turn randomly blue & transparent after saving


very often when I reopen a saved file some materials only show up blueish and transparent.
This happens with various files and to different materials. It’s also not always the same material this happens to, but switches randomly.
I tried to renew the links to the image files, tried to replace them, but with one material or another it will happen again.
I can fix it sometimes by changing the saturation, but this doesn’t always work and is very annoying anyway.
I couldn’t find any proper solution yet.
I am using a Rhino7 on MacBook Pro, 2018
macOS Big Sur 11.4

Can anyone help me?
Thank you!

One Example of many:

Hello - is the image a rendered display mode? Is that mode set to default? What happens if you do a full render?

Please run the SystemInfo command in Rhino and copy/paste the results here.


Hello Pascal,

thank you for replying.
Yes, it’s the rendered display mode and yes, it is set to default. I started only a render preview now and the materials seem to show up properly (though weirdly enough parts that should be invisible due to the clipping plane show up too) (s. attached screenshot). I had to stop it now, because it already takes way too long. I never use the proper rendering in Rhino, because it takes so long (it’s more a leave it overnight kinda thing) and never looks right because I haven’t got myself into all the render settings, but rather work with the exported display image in other software or take the model to Twinmotion.
Anyways, when I print to pdf or use the view capture to png, the materials appear as broken too.

the System Info:
Rhino 7 SR6 2021-5-7 (Rhino 7, 7.6.21127.19002, Git hash:master @ aec74c050f3ca28ab3cfd6882e9453a52366a9b7)
License type: Evaluation, build 2021-05-07
License details: Cloud Zoo
Expires on: 4456706-11-15

Apple Intel 64-bit macOS Version 11.4 (Build 20F71) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro15,1
Language: en-DE (MacOS default)

AMD Radeon Pro 560X OpenGL Engine (OpenGL ver:4.1 ATI-4.5.14)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 560X
Displays: DELL U2515H (118dpi 1x), Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro 560X (4 GB)
Color LCD (1680 x 1050)
DELL U2515H (2560 x 1440 @ 60.00Hz)

USB devices
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Apple: Apple Magic Mouse
Broadcom: Magic Keyboard

Third party kernel extensions

Third party plugins
/Users/sisiclaro/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libDLRhinoNative.dylib
/Users/sisiclaro/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libPolygonCruncherSDK.dylib
/Users/sisiclaro/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libSyncData.dylib
/Users/sisiclaro/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libomp.dylib
/Users/sisiclaro/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp/libc++.1.dylib

Rhino plugins that do not ship with Rhino
/Users/sisiclaro/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Twinmotion Direct Link 2020.2.rhp “Twinmotion Direct Link 2020”

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.6.21127.1002
/Applications/Rhino “PanelingTools” 7.6.21127.1002
/Applications/Rhino “AnimationTools” 7.6.21127.1002
/Applications/Rhino “Renderer Development Kit” 7.6.21127.1002
/Applications/Rhino “Displacement” 7.6.21127.1002
/Applications/Rhino “Legacy Rhino Render” 7.6.21127.1002
/Applications/Rhino “Commands” 7.6.21127.19002
/Applications/Rhino “Import_OBJ” 7.6.21127.19002
/Applications/Rhino “export_xaml” 7.6.21127.19002
/Applications/Rhino “QuadRemesh” 7.6.21127.19002
/Applications/Rhino “export_OBJ” 7.6.21127.19002
/Applications/Rhino “RDK_EtoUI” 7.6.21127.19002
/Applications/Rhino “Export SVG” 7.6.21127.19002
/Applications/Rhino “MeshCommands” 7.6.21127.19002
/Applications/Rhino “Export_DAE” 7.6.21127.19002
/Applications/Rhino “PDF Export” 7.6.21127.19002
/Applications/Rhino “IGES Export Plug-in” 7.6.21127.19002
/Applications/Rhino “Import_SVG” 7.6.21127.19002
/Applications/Rhino “BlockEdit” 7.6.21127.19002
/Applications/Rhino “Export_AMF” 7.6.21127.19002
/Applications/Rhino “Rhino Render” 7.6.21127.19002
/Applications/Rhino “Import_DST” 7.6.21127.19002
/Applications/Rhino “PLY - Polygon File Format Export” 7.6.21127.19002
/Applications/Rhino “Import_AMF” 7.6.21127.19002
/Applications/Rhino “RhinoCycles” 7.6.21127.19002
/Applications/Rhino “IronPython” 7.6.21127.19002
/Applications/Rhino “Grasshopper” 7.6.21127.19002

Thank You!

Hello - does the clipping plane affect the blue-stuff in Rendered mode at all?



no, it does not. The issue appears with or without clipping plane and also in completely different files.
Sorry, if this was confusing,

Hm… Can you send us a file? Preferably the most minimal one that shows the problem - please post here or send to with a link back here in your comments.


Hi Pascal,
sorry for not replying earlier. I didn’t have a small file and would have needed to invest some time to get one ready for sending, but unfortunately time is scarce. I now saw the problem in a smaller file too and will post it here.
The screenshot shows that some boards turned blue & transparent again. But also those brighter bricks are not supposed to be like this, but in a similar tone like the the darker ones. In other files I noticed materials completely switching, like the texture of some scissors block was suddenly on a roof and other things.

Here is the link to the file.

Thank you!

just a little addition:
I just opened a less reduced version of the same file again and the issue got to a whole new level:

This is a 850MB file, not sure if it’s too much, but here would be the link to this one too.

Thank you!

@mk15 - your file looks correct, so far, here. Does a full rendering look correct?


FWIW, the clipping plane issue is already on my list: RH-62567 Artifacts with Clipping Plane

@pascal Yes, it is rendering normally, but as mentioned before I work a lot from “View Capture” and do post-production somewhere else, so preferably, the materials should also be alright in display mode.

Here in rendered display mode.

Here in a started render.

@nathanletwory Thank you, good to know.

@mk15 - can you please try: open Rhino Preferences > Display modes > Rendered page and click on Restore Defaults at the top right… does that do anything good? I’d do this in a fresh session, with only one file open.


may not hurt to grab a new service release from Rhinoceros>check for updates

@pascal - I did, unfortunately the issue stayed the same.

@theoutside - yes, thanks. I just updated to the newest version. At first I thought it was different, at least one file didn’t have the problem at first sight. But opened others and there it was again. Seems less though. But since this always appears in a new form and on different objects everytime I open a file again, it’s hard to say if it won’t be more again. I will observe the coming days.

Are you using imported materials from a 3rd party rendering engine by any chance? Escape, twin motion, etc.?

no, I use rhino materials or custom made from images. nothing otherwise.

Did you try already importing a 3dm file into an empty 3dm file?

the images you are using… if you remove them does it repair itself?