Rhino 7 Mac Slow

I´m working with architecture models in Rhino 7 on my MacBook Pro 2018 (2,9Ghz i9, 32gb RAM, Radeon Pro 560X 4gb) and its really slow when working with imported drawing.
If I import a drawing of a house with maybe 10 000 - 50 000 2D curves and moves the curves it takes 5-10 minutes before it moves and I can continue. How to make it faster because I think that it shouldn’t be like that?!

It’s important to remember that McNeel has not added support for the Metal API to Rhino and won’t be doing so anytime soon. (I think it’s on the roadmap for 8 or 9 but ???)
This is important because it means you have no GPU acceleration on MacOS. You can have the fastest graphics card out there and you won’t see improvement because Rhino is really behind on this and blames Apple for dropping OpenGL.
I have a 2013 MBP w/GPU and a 2018 Mini and the performance on them is identical. It’s a real shame.
I purchased a cheap windows machine with an old i5 and just built-in intel HD graphics with 16GB RAM and immediately saw much, much better performance. But now my workspace is cluttered, I can’t do CAD on the go, and I generally grumble and curse Rhino every time I have to switch to the PC. I’ve been looking for an alternative for a year.

I do not believe that McNeel does a good enough job noting that Rhino is all but unusable on Mac for serious projects. I sometimes think they shouldn’t advertise or even develop the Mac version - then I wouldn’t have made the mistake of buying it. I have hopes that they will eventually implement Metal and give us what we paid for, but until then you simply won’t get decent performance on MacOS.

My suggestion is to buy a copy of Windows and install it via BootCamp. You’ll need to reboot your entire system into Windows to do CAD, but that’s the only option if you don’t want a second computer and still want to stick with Rhino.

It shouldn’t be like that. Can you send us the model that is causing 5 minute delays between frames?

also see if you have blocks hanging in the dwg or whatever file you have, that is one of the biggest slow downs currently. use selblock and hide and see if that already improves the performance.