Rhino 7 - Linetype CRASH

Hi there everyone!

I have noticed something rather strange happening to the Linetypes Properties.

I wanted to assign a dashed Linetype to a curve, but it was still displaying it as continuous. I played with the linetype scale, but with no results. Than I tried to make my own dashed Linetype. I also noticed that the embedded linetypes have strange pattern configurations.
For example, for the dashed line instead of showing something like “1.00, 2.00” it showed “1.00, 0.00, 0.00, 0.00, …” which makes it continuous, also without the possibility to edit it.

So I tried to create a custom Linetype with “1.00, 1.00” and Rhino just stopped working.

Here is a print screen of the situation.

Has anyone else experienced something similar?

Cheers guys!
Screenshot (15)|690x388

1 Like

Linetypes are a file property, they are stored in the individual Rhino document, not part of general options. The default values for linetypes are in the document templates, but can be modified by anyone opening the file. The default values are the same for all of the default templates, Dashed is 5.00,5.00 and Hidden is 2.00,2.00 for example. The first value is the line value, the second is the space value.

I made a custom linetype here with 1.00,1.00 and Rhino did not crash. (V6+V7)

Maybe post the file which crashes Rhino (if it’s repeatable)?

Also note that if you create a very fine dashed linetype and apply it to a number of long curves, it could crash or hang Rhino just because of the sheer number of segments it has to calculate for the display. If a dashed linetype looks continuous, it is usually because the linetype scale is far too small for the length of the curves.

Hi @Helvetosaur

Thank you for answering my complaints and for your explanations!

I tried out your advice. This time it didn’t crash. What happens though, is that every time I try to create a custom linetype, no matter the values I put in, it always jumps back to “1.00”.

Do you know why this might happen?


It does work a bit oddly here, not extremely intuitively, but it looks correct. How it seems to work:

First hit the ‘Add’ button to add a new ‘undefined’ linetype. It puts in just ‘1.00’ and shows you a continuous line. If you then modify the 1 and add other numbers, the linetype will update in real time.

thats right.
I but if I modifie to create a dashed line say, “1.00, 2.00” and hit OK, then open it in properties again it jumpes back to 1.00.

no matter how many times I edit it it jumps back to 1.00…

Hmm, OK, that’s not happening here. What version number of Rhino 7 do you have? (Help>About)

15 posts were split to a new topic: Linetypes cannot be edited

I have similar problems. What ever i enter as a linetype pattern, it jumps back to 1,0 after closing and reopening the options dialog.

Maybe its a localization issue, i noticed that for example the official Dashed pattern is: 5,00, 5,00

Notice the comma as decimal place, IMO it should be 5.00, 5.00

I am using Windows 10 german and Rhino 7 English.

Also it fails to import acad.lin - it imports, but when i close the options window and reopen it, the imported linetypes are gone.

I also managed to get Rhino into a non-responsive state by playing around with the linetype pattern a few times.

Another thing i noticed, if i copy for example the Dashed linetype, the pattern is messed up, it reads: 5,00, 0,00, 0,00, 0,00, 5,00, 0,00, 0,00, 0,00

Looks like a bug to me.

seems that I have

Version 7
(7.0.20314.3001, 09/11/2020)


Just tried again. If i use 5.00, 5.00 as a pattern, clicking OK in the options dialog doesnt do anything anymore, and when clicking cancel the options window closes, but i cant start any new commands. I can still pan and zoom, but no new commands will be started and i have to close Rhino in taskmanager.

Maybe its worth trying to install the german version and see if it works…

exactly this same thing happens to me

Same happening at our office, version : 7.0.20314.3001
Very problematic for daily simple tasks like editing CAD drawings
@bobmcneel, is it just a bug in the current version ?

Why did we lose the ability to edit linetypes inside Rhino in V7? How do I find the file I can open and edit manually?

Same happens to me:

  • I can’t edit current linetypes.
  • I can edit new lintypes, but they go back to default once I close the window.
  • Rhino also crashed while trying to change linetypes.

The default linetypes are no longer editable in V7. You have to create copies of them using the Copy button in the linetype dialog box. Those you should be able to edit.

Are you running a non-English Windows with regional settings that use a comma as a decimal separator?

same problem here:

I can’t edit current linetypes.
I can create new lintypes, but they go back to default once I close the window.

I have the german language pack installed.
I have tried the english version and the problem was the same.
Also tried to use point separator instead of comma separator, but still no success.


@HPN this should be fixed. What service release of version 7 are you on? I believe the fix was in 7.4.

I think it is fixed in 7.4, I teported the same bug last week.

1 Like

Thanks @Holo!

Hi Travis,
thanks for the fast reply.
I was not aware of Release Candidates. I installed 7.4 and now its working.

1 Like