Creating custom linetypes

In Rhino 7 I want to edit some linetypes and create some new. But in the Options menu under Linetypes the pattern-values of the default linetypes (continuous, border, center, dashdot, dashed, dots and hidden) are greyed out/uneditable.

Also their units are displayed with comma’s instead of dots which perhaps has something to do with Dutch as the default language setting in Windows (in Dutch we 4.37 is written as 4,37). For example, the pattern of hidden is written as: 2,00, 2,00.

When I create a new linetype I have to use dots instead of comma’s to get a result in the preview. But when the options menu closes the pattern value resets to 1,00.

Anybody know how to fix this behaviour?

Hoi Kevin -

That issue has been fixed and is available in the current release candidate - you’ll have to change your update frequency to get Rhino to download and install that one.

Thanks for the heads up, had to change my update frequency to Service Release Candidate instead of Service Release to get the latest fix.

-edit: the default linetypes are still greyed out, is there a way to change them? I’m trying to set-up our template for Rhino 7 and would like to customize those patterns.

Unfortunately I’ve stumbled upon another somewhat related issue. In the options menu under Annotation Styles, whenever I try to delete a style Rhino freezes. It still runs according to the task manager, but I can’t click on anything and just get that Windows sound when you click on something that’s inactive. Usualy that is because there is a pop-up somewhere you need to click, but I can’t see one. Is it possible that the pop-up that asks to confirm if I want to delete the annotation style is behind the Options menu?

Ugh - so far I cannot repeat that here in the latest - at what point does it lock up, as soon as you delete or on exiting the Options dialog, or?
The default linetypes are not editable, you need to copy and edit the copy.


As soon as I hit the delete button.

Would be nice to be able to customize those. One of the greatest things about Rhino always was the ability to change anything to your liking.

From a quick test, that pop-up always appears at the center of the screen. Can you resize the Document Properties dialog before hitting Delete so that you can see what comes up at the center of the screen?

Found a solution.

I work on two screens (laptop and secondary screen). My laptop has a resolution of 3840 x 2160, with Windows Display Scaling set to 200%. The secondary screen is a 1920 x 1080 screen with Windows scaling set to 100%. When I unplug the second screen and try to delete the Annotation Style the pop-up appears. I guess it has something to do with dual screens and/or Windows Display Scaling.

Hello - if you hook up that monitor again, check to see that Windows makes the expected monitor primary - we ran into a situation here where manipulating the primary and secondary screens - even if no change was ultimately made - cleaned up a problem for a customer - note it was a different problem but clearly this has some effect in some circumstances, so worth a look.


Hi Pascal, the additional monitor is the secondary monitor according to Windows. I noticed the same issue with the Text-object pop-up. When Rhino runs on my secondary monitor the pop-up does not appear. When I unplug the secondary monitor it works fine. If I reconnect the monitor and drag Rhino bag to the secondary monitor Text object works fine. Deleting an Annotation Style only works not, that only works on my primary monitor.