Rhino7 default linetypes view in options panel broken

just installed from scratch Rhino7 and default linetypes in linetype options panel don’t show correctly.

Hello - can you please run SystemInfo in Rhino and copy/paste the results here?


Here it is.

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Commerciale, build 2021-01-21
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 7.8Gb)

Computer platform: LAPTOP - Plugged in [70% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 12-23-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA GeForce MX150 (NVidia) Memory: 2GB, Driver date: 12-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.09
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-31-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\6.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hm - it is hard to imagine the TwinMotion plug-in being at fault here but just ot make sure, please disable that plug-in in Options > PlugIns page and then close and re-open Rhino - is that any better?


You were right, it makes no difference.

I just updated to 7.3 but the problem is still there.

@lowell - do you have an idea what might cause this?


back on this.
I’ve noticed that if I click i.e. on the “border” linetype I get the correct pattern, in mm in this case:

Then, if I switch to inches, this is what I get:

Back to mm and this is the result:

Inches again:

This just switching the units type.


Hello - I do see slightly odd numbers here - not sure yet why that is - but they stay when switching back and forth - is the problem you see in any file? If not, can you please post a simple file that shows it?


Yes, any file: starting from scratch, opening old files which used to work correctly on Rhino6, …

@aneuwahl please open Options > Advanced page, and filter the view for


Set that to False and see if the page behaves better… any luck?
RH-62919 Line types: ETO dialog definitions wander


Whoa! This is magic, now it works flawlessly.
Don’t know what it does, but that’s it. Thank you!

Well, not any good kind of magic really, it shuts off the dialog code that is supposed to magically work better…


So, even magic has its limits… 8^)

RH-62919 is fixed in the latest Rhino 7 Service Release Candidate

Just updated to 7.4.21067.13001, re-enabled UseEtoLinetypePage and now it works. Great!