Rhino 7 installation fails rhino.msi -2417023293


I installed Rhino7 today and when changing the language in the installer settings I’m greeted to this:


And after that the installer fails with the rhino.msi error.

I’ll attach the log here:
Rhino_7_20201216155249.txt (6.1 MB)

If I accept the defaults and install with the german language pack the installation succeeds, so no harm there, just wanted to report this, so the next person can get a better error message.

Cause: The installer failed to install rhino.msi with error code 1603. This article explains how to resolve that error.

Solution: Read https://wiki.mcneel.com/rhino/6/install/error/1603.

Hi @scottd,
thanks for getting back to me.

I’m sorry I should have mentionend in the original post I tried that article, but it did not help me resolve the problem.

Steps I took to get it working:

  • Check for Windows updates -> all up to date
  • Install the windows installer fix tool as described in this post: Rhino 6 update/install error rhino.msi: -2147023293 [SOLVED] . -> This could not recognize the rhino 7 installer.
  • De-Install my old installation of the Rhino 7 WIP, as i assumed the installer might get confused by it. -> Still did not work
  • finally: Out of a hunch, Disabled the option for the english language pack in the installer -> Rhino 7 installed successfully and works as expected, though I typically don’t use the default german language pack normally.

The takeaway for me is, that the error message and also the solutions found here on the forum did not help to find what seems to have actually caused the error on installation. Maybe there is some info in the log, that can help supply a more fitting error message.

Thanks @scottd for this - it’s actually not the answer, sadly.

What’s happening here @lando.schumpich is that you’ve entered a license key after clicking the gear in the installer. The bug is logged here, but not yet fixed: https://mcneel.myjetbrains.com/youtrack/issue/RH-61465

A temporary workaround is to install without the license key, then enter your key after you start Rhino.

1 Like

Hi @brian,

Yes, you are totally right, the first few times I tried to install, I entered the license key directly in the installer, but as you can’t copy paste into the installer fields, I got lazy after a few failed attempts :sweat_smile:.

Thanks I’m marking your answer as the solution.

@scottd 192 / 5000

Resultados de tradução

Help me please. I downloaded the Rhino7 trial yesterday and I can’t install it, this same error appears and I can’t fix it. I followed all the guidelines I read here, but nothing resolved.

In order to work around this, you need to just click the “Install Now” button on the installer without clicking the Gear button. Once Rhino is installed, you can enter your license key. If that doesn’t work, please DM me the install log file that is shown in the installation failure dialog box.