Solidworks sldasm files don't import geometry

Solidworks sldasm files dont import geometry.

Do you have the support files?

You need to have both the .sldasm files as well as the individual .sldprt files in the same folder. Then when you import the .sldasm, it will grab all the part files and assemble them correctly in Rhino.

@Helvetosaur is correct.
SW Assembly file contain no part data, only transformations.
That’s why you need the SW Part files in the same folder as the assembly file, so there are parts to assemble.

I see that and its really
fileList_wishbone_suspension


confusing me. As I get winrar folders from GrabCAD that have following listing. Two types. One is Solidworks SLDASM and other is for another project in CATIA. All SLDASM downloads from GrabCAD are like that.

Yeah, I think more recent sldasm files include the parts. Maybe we just do not not support that, I’ll ask…

-Pascal

I’m pretty sure SW assembly files still do not contain the part. They sometimes contain a mesh or a representation of the parts as of the last saving - you used to be able to open an assembly in edrawings viewer and view the assembly.

There’s some parasolid files (X_T) in that list at the top, can you open them?

1 Like

Does this work in R7 or R8? I seem to be having the same trouble as the OP but importing any combination of SLD file formats (SLDASM, SLDPRT) doesn’t result in the full geometry in Rhino. Best I can get is 4 tires of a pickup truck. Any ideas?

SystemInfo-R7

Rhino 7 SR37 2024-1-4 (Rhino 7, 7.37.24004.15001, Git hash:master @ e428f0ecb09d755f844c48e5098aba5f8baf55fa)
License type: Commercial, build 2024-01-04
License details: Cloud Zoo

Windows 10 (10.0.17134 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version: 31.0.15.5161
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\Armen\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ColorPicker\6.0.0\ColorPicker.rhp “ColorPicker”
C:\Users\Armen\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.37.24004.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Armen\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 7\Plug-ins\Import_SolidWorks.rhp “Solidworks Import”

SystemInfo-R8

Rhino 8 SR6 2024-3-14 (Rhino 8, 8.6.24074.01001, Git hash:master @ def4e7ae5a5339578727a42cbd95e31d75b3faf0)
License type: Commercial, build 2024-03-14
License details: Cloud Zoo

Windows 10 (10.0.17134 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 2-15-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 551.61
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-15-2024
Driver Version: 31.0.15.5161
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24074.1001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24074.1001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24074.1001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24074.1001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24074.1001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24074.1001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\Import_SolidWorks.rhp “Solidworks Import”

Hey folks, hoping I’m missing something obvious, but I still can’t get this SW import to work out. Thanks for any ideas on what to do.

There are only 3 .sldprt files in your list above. The .sldasm only tells you how to assemble the part files, there is no geometry in it.

Try opening the three .sldprt files individually. Are all the parts you expect there? If not, you are missing some files…

Thanks for looking. Yes, I’ve tried to open each .sldprt individually. This is from a detailed model of a pickup truck on grabcad here. Looks from the significant amount of effort from the OP and the comments that there must be complete geometry in the package. Maybe the snafu is due to the model’s scale?


For example, here’s the command line report from an .sldprt import attempt:

Opened file: C:\Users*\Downloads\toyota-tacoma-2016-1.snapshot.4\TACOMA.SLDPRT
Part - TACOMA.SLDPRT
Successfully read file “C:\Users*\Downloads\toyota-tacoma-2016-1.snapshot.4\TACOMA.SLDPRT”

Rhino import options:

image

but nothing in Rhino to select.


TACOMA-Combiner1.SLDPRT imports as one tire:

hrtegrwfedm.SLDPRT imports as four tires:

Hi am -

It looks like the .sldprt files are containing mesh objects and Rhino isn’t currently reading those. We’ll take a look to see if that can be changed.
-wim

Great, thanks for looking into it.

In the meantime, does anyone know of another method that can get sldprt mesh geometry into Rhino? Is there maybe a Grasshopper reader that would use a different method than Rhino’s?