Import from solidworks problem


I’m trying to open a .sldprt file from a colleague who uses SolidWorks 2015 (this also happens with the sldasm files too). When I attempt to open the file, nothing appears - it just looks blank. The command window says the file was successfully read and imported.

I’m using Win7 and Rhinoceros 64 bit V5SR11. They are using SW2015.

It seems that the SW2015 files are not able to be imported into Rhino? I saw an thread about SW import from 2014 in the forum suggesting the datakit importer might not be able to read SW2015 files yet - is the SW importer going to be updated soon?

Any other suggestions?



That’s too new for V5 Rhino. We will have updated SW2015 support in Rhino V6.
If you have a SLDPRT file you need opened in Rhino, I can do that if you need it.

Upload the part using the tool on the Support page tool. Use as the notification address and describe the problem so I’m reminded of the issue.

Hi John

That would be fantastic, as this is hopefully a one-off, but I’ve actually got a whole stack of files for a component assembly (currently in a solidworks pack and go file, but I could disaggregate). Would that be too much?


Hi John,

What process are you using to import the SW15 into Rhino V5? I would need to do this quite regularly so it would be handy to be aware of any software or add-ins that may help…


V5 does not support SolidWorks 2015 files.
The WIP that will become V6 just recently got the new library for importing SW 2015 files.

Oh, so youre using a beta version of V6 to import & convert?

Pre-beta. Work-In-Progress

Thanks for your help John,

I tried the WIP (details below) and it doesn’t seem to import my SW 2015 files. I get: “Can’t open that file” message. I tried several .sldprt files…

I’m running:
Work In Progress,
(6.0.15076.10541, 17/03/2015)

on W7 64 bit.

How can I help debug this?



I tested the fix a couple weeks ago using a bunch of the SolidWorks supplied tutorial files. Can you please send me a couple part files so I can test it here?
If it fails, I can send them on to the developers of the function library we use in a bug report.


i see some other rether product… they have plugin for application…

will there be a plug for solidworks to run Rhino so which might be easier?

I’d like to mention how good is the import from SolidWorks.
Robust and fast, it never failed me. And considering how sloppy the geometry can be from SolidWorks, I think it’s quite an achievement.
I used some other translator from them, such as the CATIA import for Rhino, and they are all excellent.

1 Like

Steve sent me the files.
They would not open for me in Rhino.
I opened them in SW2015 and could find no problems so I used SaveAs to make new copies.
These copies opened in Rhino just fine.

I’ve sent them onto the developer to see if he can figure out what’s happening.
There appears to be something not quite kosher with the files.

Thanks so much for the prompt help!



I am also trying to open SolidWorks 2015 part files in Rhino 5.

With a macro I generate from SolidWorks part files the centerline of pipes and stores them as Iges. these Iges are loaded into our bending machine

Is there meanwhile a solution to this problem in Rhino 5?
If not, what is the status on Rhino 6?