Rhino 7 : Import CAD doesn't work as expected

Here’s the original CAD file

Here’s the import options
Here’s the resultant file in Rhino

Help !!!

(Just so there’s no confusion - the Rhino file is completely clear of any lines or objects / Cad blocks.
All layers are empty except for those few random elements you can see)
That’s at full extent btw

There are some ACAD_Entity errors flagged at import… previous posts seem to indicate ‘tough shit’ but I can’t see why I can export from CAD into Rhino

Hello - can you post the last few lines of CommandHistory (F2) right after the import?


Yes, sure . As follows. There are 126 lines of the “Unsupported entity type: AcDbProxyEntity, ACAD_PROXY_ENTITY” entry then…

Unsupported entity type: AcDbProxyEntity, ACAD_PROXY_ENTITY
Model space objects read: 126, skipped: 14821
Paper space objects read: 0, skipped: 0
Block definition objects read: 78, skipped: 0
XRef objects read: 0, skipped: 0
Successfully read file “C:XXXXXXXV-50-P100_KS.dxf”** edited out actual filename as it detailed client
Command: _CommandHistory

These are entities created by either vertical versions of AutoCAD (like CIVIL or ARCHITECTURE etc.), or third-party add-ons: you will not have any editing access to these blocks in their native format without using the same software that created them.

Basically, Rhino cannot read these object types.

Hope this helps.

– Dale

1 Like

well i didn’t want to edit… merely view (to pull off dimensions)
seems a pity it doesn’t work… your response is the same in the previous post… so not unexpected.
It opens in ‘Vanilla’ Cad… just not Rhino

If you can open it in the special AutoCAD again, and export as a 2007 DXF file, that should strip the “smarts” out of these proxy objects so you can see them in Rhino.

1 Like

I did try that and it didn’t seem to work. Edit no I exported as a more recent version. I’ll try 2007 instead thank you.
I’ll play around a bit more and see if I can get it to work… and report back. Thanks all for quick responses.

This might also be helpful.


@John_Brock , I’m afraid an export to 2007 AutoCAD didn’t work.
however when I run the exporttoautocad function which @dale suggested, I receive the error (in CAD)
“Command not allowed because drawing contains objects from a newer version of this application”.
I am using AutoCAD 2017 you see…

I’ve also tried exporting as .iges from CAD (Rhino recorded 0 objects) and 2007 .DXF
Basically keep getting these ACAD_PROXY_ENTITY errors no matter what
Ah well. Thanks to @dale and @John_Brock for your help. AutoCAD closed system it would seem