Rhino 7 hatch bug

Hey I have some troubles with creating hatches in Rhino 7. Few days ago everything was working fine. I was trying to solid add hatches with python code, but nothing was added to the document, even though there was no error in the code. I tried to run same code in Rhino 6 and everything was working fine. I tried to reopen Rhino 7, open another file, switch on/off computer and to reinstall Rhino. Nothing worked.
Even adding hatches using rhino ui is not working. When I press ctrl + a to select everything I can see in the properties that hatch was also selected and I can play with it’s properties - It is just invisible. When I select fill style to gradient it strats to be visible for a moment, bat after deselecting it disappears. I tried to play around with different scales but it didn’t work.
Could anyone help with that? I feel I done everything I could think of.
Thanks in advance
PS I’m attaching few screenshots

Hi Jacek -

That sounds like a display issue, possibly on an older AMD GPU?
Please run the SystemInfo command and copy-paste the result here.

1 Like

Thanks for your reply Wim. Here is system info:

Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Commercial, build 2022-11-04
License details: LAN Zoo Network Node

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 6-3-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.02
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-3-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\jacek.grzegrzolka\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\SpeckleConnectorRhino.rhp “SpeckleConnectorRhino”
C:\Users\jacek.grzegrzolka\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\ggRhinoGSA\\ggRhinoGSA.rhp “ggRhinoGSA”
C:\Program Files\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21089.1448

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Jacek -

I’d start by installing updated drivers for that GPU.
When you open the Notifications panel in Rhino, you’ll find links to the correct website.

1 Like

Thanks Wim, I will try to update that and let you know if it helped. Also could there be another reason for this, because 2 days before everything was working fine with the same driver - I’m afraid that just updating the driver could not help that much.

Hi Jacek -

Do you remember what might have changed on your system? A Windows OS update? A new plug-in or version? …

Just taking a wild guess here but is the object color of the hatch completely transparent? That could possibly make something like this happen.

Thanks @wim @Trav,
I wasn’t able to install drivers but in the meantime noticed strange thing:
Hatches are visible in the 3d space - I can draw a rectangle and apply hatch, but when I try to do same thing in the layout view it stops working (trying to add to the layout space not to the model space).
Do you have any ideas what could cause that?

Ok I finally found out what was the reason. A really stupid thing - my layout display view was by default set to wireframe. After changing to shaded solid hatch is visible also on the layout. Didn’t know that I can also change display modes for pages. Sending the printscreen, maybe someone in the future will have a similar issue. Thanks for your replies.

Hi Jacek -

I’m glad that you found something that makes things “work” for you, but, just for the record, we recommend leaving layouts in the wireframe display mode. There is no reason (or, at least, should not be) to put these in shaded mode to see hatches that are created on the layout:

I still believe this is an issue with your GPU drivers.