Rhino 7 Error: Crashes, Black Screen, Cannot Select Anything

Updated to Rhino 7 and purchased the license after the trial period recently. I’ve been able to work within the projects I am trying to open for the better part of the last four months, but today an error occurred that has me unable to open any of my previous projects.

The screen will either tell me that Rhino has encountered an error and needs to close or load a black screen with Viewport “unnamed” that will show me the rest of the project if I minimize the screen and maximize it. Though I am able to see my model, I am unable to click, drag, or select within the viewport.

I am using Bootcamp on a 16-inch 2019 MacBook Pro, 2.3 GHz 8-Core Intel Core i9, AMD graphics.

SystemInfo Command:
Rhino 7 SR25 2022-11-22 (Rhino 7, 7.25.22326.19001, Git hash:master @ 2a680490f96a04550d1f39158b859c4f7739d024)
License type: Educational, build 2022-11-22
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon Pro 5500M (AMD) Memory: 4GB, Driver date: 11-11-2021 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context FireGL 27.20.14540.15002
> Integrated accelerated graphics device with 7 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-11-2021
Driver Version: 27.20.14540.15002
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\XXXXXXX\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.22290.1357
C:\Users\XXXXXXX\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2019.11.5.949\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\ccurti12\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I would keep checkings for updates on the driver as well.

Thanks, Japhy.

Just tried this and, unfortunately, it is doing it still. I uninstalled everything associated with Rhino, Chaos, etc., and it briefly worked, but it is back to crashing anytime I open a file now. I am unsure why.

Does Rhino stay open in Safe Mode? That’s available via windows app search

Generally, no. I can open other files just fine, which is odd. I think it has to do with materials, maybe, as it asks me if I want to keep or delete previous materials that are no longer reading correctly.

I just opened it in safe mode and it’s lagging heavily and only displays in Wireframe, but it’s open currently.

Are you still on OpenGL 4.6? Try 3.3

I dropped it to 2.1

I believe the issue stems from Legacy V-Ray materials, because when I tried to copy and paste work into another file, it crashed as well and the last visible line of text was “Importing (0) Legacy V-Ray Materials… Done”