How to Stop Rhino 7 from Freezing My PC?!


Rhino locks up my entire computer repeatedly, yesterday 6 times. Is there some way to stop this from happening? I have the latest drivers etc. Any help would be GREATLY appreciated!


Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Educational, build 2022-11-04
License details: Stand-Alone

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: AMD Radeon HD 7700 Series (AMD) Memory: 2GB, Driver date: 5-11-2021 (M-D-Y). OpenGL Ver: 4.6.14831 Compatibility Profile Context 21.5.2 27.20.20903.8001
    > Accelerated graphics device with 8 adapter port(s)
        - Secondary monitor attached to adapter port #0
        - Secondary monitor attached to adapter port #1
        - Windows Main Display attached to adapter port #2

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: ATI Technologies Inc.
  Render version: 4.6
  Shading Language: 4.60
  Driver Date: 5-11-2021
  Driver Version: 27.20.20903.8001
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.24.22308.15001
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.24.22308.15001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.24.22308.15001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.24.22308.15001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.24.22308.15001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	

The latest drivers are the issue (AMD re-wrote all OpenGL drivers recently)

Go into your options and turn off GPU Tessellation. With that video card you may need to turn down the OpenGL level to 3.3 as well. Recommendation is 4gb video card.

In Rhino Options > View > OpenGL
Uncheck the option for “GPU tessellation


Sorry, forgot to mention that I had already tried disabling GPU tessellation and lowered Antialiasing from 8x to 4x. Unfortunately this made no difference.

I’ll try lowering OpenGL…

Hope to get a new PC in the new year, but can’t afford it right now so really hope I can get it to stop crashing until then.