Rhino 7 Delete layers does not work pressing delete

Hello Mcneel,

(unfortunately I cannot create an account four youtrack. There is an errormessage regarding the exceeded licence.)

In Rhino 7 I cannot delete a layer pressing the delete button.
Sure, ‘right click > delete layer’ or ‘purge’ command works but in as in Rhino 6 I would like to simply press delete :slight_smile:

Best regards

1 Like

Hi -

That seems to be working fine here.
Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Hello Wim,

I tried it with an empty Rhino file and I only get the windows ‘dong’ soundeffect.

Edit:
I just downloaded the 7.0 release on my Thinkpad and there is the same error and only the windows ‘dong’ refuse sound. On both machines it works with 6.31

Rhino 7 SR0 2020-11-9 (Rhino 7, 7.0.20314.03001, Git hash:master @ 9d1a3d02b292e00d3480c301d33f414d91acdcbd)
License type: Kommerziell, Build 2020-11-09
License details: Cloud Zoo

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: Radeon ™ RX 480 Graphics (AMD) Memory: 8GB, Driver date: 10-16-2020 (M-D-Y). OpenGL Ver: 4.6.14736 Compatibility Profile Context 20.10.1 27.20.12033.1007

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 10-16-2020
Driver Version: 27.20.12033.1007
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\SimLab\Plugins\SimLab Rhino Integration\SimLabComposerIntegration.rhp “SimLab Composer Integration”
C:\Users\Bodzguard\AppData\Roaming\Grasshopper\Libraries\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - this is indeed a change in V7… there were a number of complaints, as here:


https://mcneel.myjetbrains.com/youtrack/issue/RH-56405

from users who accidentally deleted layers. So now, the red ‘X’ at the top of the layer panel is the way…

-Pascal

Thank you very much pascal, so now its a feature and not a bug. :wink:
I must say, I never had the issue reported in the bug tracker.

I guess, enabling this as an optional feature within settings is not worth the hassle for one user? :nerd_face:
When I import geometry from various project I mostly use ‘purge’ command after reorganizing the layers - But in other cases, pressing DEL feels faster in the workflow for myself.

As is sadly too frequently the case, the few have spoiled it for the many… :frowning_face:

Wellll, I don’t know - for one thing, Layers did not behave as the other panels do, for one thing - it was the only one to delete on the delete key, but the comments on the Disco item show it was an actual workflow problem for users I was bitten/irritated by this a number of times myself…

So the current workflow is different than it used to be but I would argue more consistent and less susceptible to causing errors. My 2 piasters…

-Pascal

1 Like

Well I think the problem was the layer panel’s keeping focus when the cursor was outside it, not the fact that the delete key actually worked to delete layers. I have been using the delete key to delete layers for years and never had a problem. On top of that, the layer stack is undo-able, so if you do make a mistake, you get stuff back. Not any different than deleting some accidentally selected objects…

2 Likes

Agree. I’ve accidentally deleted layers after moving the cursor off the layer panel. I also like to delete layers, just like objects, with the delete key.

1 Like

This is pretty lame.

When you accidentally delete layers, undo.

Can we have DELETE back ?

1 Like

one more vote for the DELETE key

But maybe a compromise:
For me it seams most intuitiv to have the Delete-Key only active after a mouse klick in the corresponding GUI-Element, if the mouse is still over the GUI-Element / has Focus.
(i mean you click on the Layer-Name, or you click on the RhinoObject in the Viewport … before deleting them)
As soon as the mouse leaves / Focus is lost, the Delete Key should loose its power and not gain it back just by mouse-Over.

I think Input-Focus is a general GUI-Topic for Rhino to be looked at :
… if you enter some Properties -for example the Name of an Object- and press Enter / Return, i would love to have Enter as “confirm” and the Focus should be back on the command line or the previous Element. But we get the entire Name selected.
RhinoForMac has even more ugly Focus / Enter-Return … behaviour especially for command options - and different from Windows…

and i also agree, for all user who have to adapt to work more precisely with there mouse - there is Undo…

kind regards -tom

1 Like