Raster output

yes, I didn’t realise it first but I added both 6 and 7 yesterday and have same custom settings to use the GTX GPU but neither still using it according to Systeminfo.

It may be worth a clean install of your nvidia driver-

grab the latest one, then install it using the custom/ advanced setting- then use the clean install checkbox that appears in the custom advanced dialog.

I’ll give it a go, thank you for everyone’s help by the way.

Hi, I reinstalled the driver with a clean install and reset Rhino to use custom settings but still no luck. I also set my graphic settings with rhino to be High performance also but still no luck, anything else I can try?

I also tried all the solutions in this thread

Rhino 7 - BLACK screen in Rendered View - #16 by theoutside

I saw it mentioned in the thread to call the Barcelona office for Europeans with trouble was wondering when will it reopen because presumably shut as an office over the weekend.

You can call seattle- we are here till 5pm pst.

206-545-6877

Ignore sorry i hit enter by accident, thank you

I looked at the systeminfo report that you sent in via email and it doesn’t make much sense to me. It shows both an nVidia GPU and an AMD GPU installed and that Rhino is using neither of them. @jeff this is the discourse post for the private tech support we received. Probably best to answer here so we don’t get muddied up in email support. I’m not sure what to try in this situation, but I’m hoping Jeff has an idea.

I will address the elephant in the room here…

What kind of laptop is this? Make, Model ? Link?

Your laptop has an AMD and an NVidia GPU installed, which makes me think it’s probably an APU.

That being said, let me first point out that Rhino (or any application on Windows) does not “choose”, “pick”, or “determine” which GPU it uses…there is no way to do that even if it wanted to. The GPU used by any application is determined by which driver gets loaded into the application’s process space at the time it loads…The driver that gets loaded is determined by Windows…not NVidia’s Control Panel, or AMD’s control panel…Windows OS is who is in charge here…nothing else.

Now, there are configurations that can be made that can force Windows to pick a specific driver for a specific application…but as far as I can tell, everyone here has already exhausted those options and things still are not working.

You’ve indicated that you always run in “high performance” mode, so then that means you don’t even need or use the AMD for any kind of power or battery saving management. Therefore, since it’s not being used, I suggest disabling the AMD GPU from within the Device Manager in Windows.

@wim and/or @pascal can help walk you through that if you’re not familiar with the process. With the AMD GPU disabled, it means that Windows has no other choice but to load the NVidia drivers for ANY application it loads. I would give that a shot and see what happens.

If that doesn’t work, then I’m currently out of ideas…my guess is that none of your applications are using the NVidia GPU either ???

Thanks,
-Jeff

Hi, thanks for the replies Steve/ Jeff,
the laptop is a ASUS ROG Zephyrus G14

https://www.scan.co.uk/products/14-asus-rog-zephyrus-g14-ga401qm-qhd-120hz-amd-ryzen-9-5900hs-32gb-ddr4-1tb-nvme-ssd-6gb-rtx-3060-wi

I didn’t think which order is was determined to be honest but I do already Windows graphic settings as Rhino using the Nvidea GPU. I always run the laptop in high performance mode for Rhino just in case really.

It definitely has used the Nvidea GPU before because I have noticed it’s usage in Armoury Crate ( ASUS ROG version similar to task manager) and likewise I can see it can using the AMD GPU in the AMD version when using Rhino. As for which program was using the Nvidea GPU I have no idea but would’ve been a game.

I’ll try disabling the AMD GPU and see what happens. Thank you again for the help, sam.

Hi, no luck

absolutely confused. I think it’s a problem with the Nvidea GPU itself, disabling AMD GPU just left laptop barely able to even load start up and CPU use at almost 70% continuously. I did manage to get Rhino working but wasn’t recognising any GPU at all. I’m going to contact Nvidea about it and look on their forums as to why it is.

If you guys have any proposals also that’d be still much appreciated. Thank you so much so far, sam.

should also mention tried rolling back to an earlier Nvidea driver but that didn’t help either.

Hello - I think I might do a clean install of the latest NVidea and AMD drivers from their respective websites

Then install the fresh ones. It may be that the installer has a clean install option - I cannot remember, in which case the uninstall may not be needed.

-Pascal

I tried with the Nvidea already but I’ll do it with the AMD now, thanks Pascal

Hi, still no luck. I’ll check with asus/ nvidea/ amd: forums/ help; and see if anyone there has an idea

Hi, so I completely restored windows and noticed something. When I first install and use Rhino before anything I ran systeminfo, Rhino is using a hybrid configuration and is using both GPUs! However… !
IMG_20211013_150157177_HDR|666x500

The second I try to draw anything the screen crashes, Rhino crashed as well and then I got blue screened. Windows said it needed to sort something, it ‘resolves it’ and when I reload Rhino same non hybrid configuration as before. However, pretty sure the laptop no longer seems to be using my Nvidea GPU at all.

Does this mean its a problem with hardware or a windows problem or something else?
Thanks everyone. sam

Hi Sam - this is starting to feel like a hardware problem to me, not that I am an expert at all … have you installed all available Windows updates as well as the most recent gpu drivers since restoring Windows?

-Pascal

Hi Pascal,

I have done it now, still don’t seem to have my favour with Rhino. Wierdly, Rhino is running a hybrid config but crashing immediately when drawing geometry as before.

sam

Hey sam- call us at 206-545-6877 something is really screwed up with your machine.