All the views are in black and Rhino 7 doesn't work

Hi, I enter my Rhino 7 and it doesn´t work. I don´t really know why the whole screen is black and there are no views. Pleas if someone knows how to solve this problem let me know. Thank you.

Hi Paula -
Please run the Rhino SystemInfo command and copy-paste the result here.

1 Like

Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Evaluación, revisión 2022-11-04
License details: Cloud Zoo
Expires on: 2023-02-12

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [42% battery remaining] ~65 minutes left

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1650 Ti (NVidia) Memory: 4GB, Driver date: 8-2-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.00
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-2-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi -
thanks for that - that seems fine.
Does this happen when you try to open a specific file or simply when you launch Rhino?

Both of them, but in some specific files it just appears one view and not the rest of them.

What happens when you launch Rhino in Safe Mode?

I have tried and, yes, it works. But one question, the safe mode works in the same way? I mean if I start a project there, i am not going to have any problem?

Hi Paula -

No, Safe Mode turns off quite a few things and isn’t meant as a fix but only as a tool to troubleshoot the issue.

Your GPU drivers aren’t all that old but, given the fact that you are running into trouble, I would update those to the latest version to see if that helps.

I´m not familiar with this kind of terms, I mean, I don´t really know what the GPU is or how to work with it. I have installed again the program but it doesn´t work neither. Thank u very much but I think I think I will need to ask someone to repair it.

GPU = Graphics Processing Unit i.e. your video card. Graphics cards have drivers, you can go to the manufacturer’s website and download/install later ones. But it seems that is not so likely that is the problem…

If you go to Options>View>OpenGL, and you try unchecking the “GPU Tesselleation” checkbox and/or moving the OpenGL slider somewhat to the left, does that help any?

Yees! I have tried it and it works! Thank you very very much! And does it work the same way or the quality of the project could change?

1 Like

Which one, Tessellation or Slider?

If it’s the tessellation checkbox, just leave it unchecked. It may be that your display will not be as fast, but at least it will work…

If it’s the slider, keep it as far to the right as works. Start at some point where it works and keep moving it to the right a notch until it stops working. Then back off the last notch. May also slow down the display a bit I guess…

In any case, it will not affect in any way the objects you are creating, it’s just the display that is affected.

@wim1 @stevebaer any other info/advice here ?

Having success by changing either one of these (the tessellation checkbox or the OpenGL level slider) is still indicative of a problem with the GPU drivers. Trying different drivers would have been the first step; the fallback being messing with those settings.

1 Like