Rhino 7 and added Images

Hi. I’ve imported an image that I’m trying to draw to get it into a 3D form. Sadly, it’s a really tedious image and is going to require time to complete. (Trace plugins laughed at me when I tried them, so I’m doing free hand.)

Everytime I save, I lose the image. It becomes a giant black shape.
I can Revert to get it back, but the extra step shouldn’t be needed. Been a while, but when I used Rhino 5 this wasn’t an issue.

I have seen online that you need to check the “Save Textures” button, but that is checked by default and it’s still returning the black box. Makes me think something is wrong here, but I don’t know how to troubleshoot it.


This is what I start with everytime I open the .3dm file no matter how I try sasving it.

I also noticed in some of my reallllly old files (like…created in 2010) that the images that should have been embedded in them are missing, even though back then I was using Rhino at two different schools + home, and had no issues passing a .3dm file with the image.

Hi Sara -

Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commercial, build 2023-02-27
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 7.3Gb)

Computer platform: LAPTOP - Unplugged [94% battery remaining] ~186 minutes left

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 12-7-2021 (M-D-Y). OpenGL Ver: 4.6.14761 Compatibility Profile Context 21.30.44 30.0.13044.0
> Integrated accelerated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-7-2021
Driver Version: 30.0.13044.0
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Thanks for the information, Sara -

Sadly, that system doesn’t do you much good to be running Rhino 7 on. Our recommendation for minimum VRAM is 4 GB.
On the Rhino Options page, under View -> OpenGL, there are 3 options that you could try to change to see if that helps with the display issues that you are running into. You’d probably have the antialiasing turned off, and, possibly, the “Level” slider a tick (or 2) to the left from max. Start with 1 tick and restart Rhino to see if that helps. Another tick if it didn’t. If the “GPU Tessellation” option is checked, try unchecking. If it is checked, try checking it.
-wim

I will try them out and see what happens.

I do acknowledge that this computer is not up to spec (you can probably image how a render looks). It’s a temporary solution while my desktop is unaccesible :frowning:


Is it strange that this was my default?
I’m using a Template that I original built back in Rhino 5, so it has a lot of non-default things in places. Wouldn’t be suprised if this is something that was set back then.

:o Setting to the farthest left tick made the image show up.

Can definetly see the performance different though; not sure the trade off is worth it, haha. Motivation to get back on the desktop.

Thanks for the assistance!