Rhino 6 trap - "wrong" subselection


#1

Hi,

I’m using the Rhino control like in sleep and don’t think about it. If I want to select an object from a group, than I press ctrl+shift and drawing a rectangle around the object. At R5 it works fine, at R6 I get long freezes since all object points in the selected area are selected. Could be nice if per default this behavior would be off. But how can I turn it off?

-Micha


#2

Rhino Options > Advanced >
Search for pointson and you will be able to turn this off…


#3

Thank you Wim, but I don’t get it, also after a restart.


#4

Hi Micha,

you can disable subselection altogether to avoid this:
_TestToggleSubObjectSelect

I had the same issue with groups so we usually work with sub-selections off unless needed.
Or maybe I misunderstand your problem since I see you saw the thread where that test command was discussed in the past…

–jarek


#5

I don’t use R6 for daily work and so I forget it. Looks like I will be old. :slight_smile:

Thank you Jarek.


#6

Strange! It works around here…

@pascal, There is something strange about this though… I seem to only be able to set one (1) of Rhino.Options.General.AutomaticPointsOn and Rhino.Options.General.PointsOnObjectSelect at a time.

That is, when I go into Rhino Options > Advanced and search for “PointsOn”, I see those 2 settings. When I change both of them (from True to False or the other way around) and then click OK to exit the dialog box and then go back in to check the state, I will only find one of them to be changed. At that point, I can change the state of the other.

Also, what is the difference between these two?


(Pascal Golay) #7

Hi Wim - both of those settings are in Options > Mouse page, you should not have to dig into Advanced… but that should also work from Advanced, I’ll check it.Yep, you’re rtght - setting these from Advanced fails, from the Mouse page works and sets the advanced setting,

https://mcneel.myjetbrains.com/youtrack/issue/RH-42536

This, if True or checked, turns on points for curves and annotation objects when they are selected.

This one, if True, allows objects that have points on to be selected as top-level objects.

-Pascal


#8

Thanks for checking! And for explaining the difference!

On the Mouse page, huh? OK.
I would suggest changing the Advanced names to Rhino.Options.Mouse.AutomaticPointsOn and Rhino.Options.Mouse.PointsOnObjectSelect but… (-;


How to turn off auto-show-controlpoints?
(Pascal Golay) #9

(That may well be why it is not working…)

-Pascal