Rhino 6 startup issue on Windows 7 machine


(Mpstek1) #1

I am trying to get Rhino 6 to even run on my Windows 7 machine for the first time and not having any luck.
I see the initial popup menu tabs and thats it . Error reporting window opens.
I have tried…

  • Reinstall
  • Safe Mode
  • Running as admin

Version 5 runs fine here.
Are there any other ways to check for specific errors ?


(John Brock) #3

Did you get an error when you installed it?
Have you tried a “Repair” using the Programs and Features tool in Windows’ Control Panel?

(Mpstek1) #5

Seems to install fine. Gives me the restart button.

(Mpstek1) #6

yes on the Repair

(John Brock) #7

Just to be clear, even after a Repair, Rhino V6 crashes when you try to start it, even in Safe Mode?
I also see you are using the cloud zoo?

Any chance you have an expired T-Splines eval installed on that computer?

(Mpstek1) #9

Yes. Even after repair and Safe Mode. Yes I’m using cloud zoo. No expired T-Splines.

(John Brock) #10

I’m going to have to get some “Bigger Brain” help for this.

(Brian Gillespie) #13

@mpstek1 I’m sorry to hear that. Thanks for sending in the crash report with your email address. It looks like this is crashing in your video driver. Can you please try updating the video driver for your WX 4100, and see if that fixes the problem?

(Mpstek1) #14

Latest Driver Installed. Still not working

Advanced Micro Devices, Inc.

(Jeff Lasor) #15

Hi @mpstek1,

We’ve been working with AMD to resolve certain driver crashes they’re seeing with their Radeon Pro WX series cards… They believe that they’ve got them fixed and will be making a drop to us some time later next week (sorry, don’t have the exact date). Hopefully those drivers will address the issue(s) you’re having. Unfortunately, the release of those drivers might take a bit more time, again, I don’t have any dates from AMD on this.

In the mean time, I will try to duplicate the crashes you’re seeing with the WX4100 I have… All you’ve done is install V6 on your Windows 7 machine and tried starting it, and it crashes? I’m afraid I’m not quite sure what you mean by “initial popup menu tabs” … if you can hit the “PrtScr” key on your keyboard before it crashes, hopefully you can capture what you’re seeing and then just paste the results… The PrtScr key takes a snapshot of your screen and places it in the clipboard… Seeing exactly what you’re seeing may help provide key information that we’re missing.


(Jeff Lasor) #16

That doesn’t look like the latest…it may be, but the date seems off…These look slightly newer…


(Jeff Lasor) #17

Hi @mpstek1,

One more thing… I’ve been talking to AMD about this problem, and they’re wanting to know if you’re using dual monitors or just one monitor? It’s possible they may want even more info in the future, so I would just ask that you provide as much detail about your computer configuration as you can… CPU, Monitor(s), Resolution(s), OS, etc…


(Mpstek1) #18


Thanks for the update.

Generally when you start rhino, the rhino new file, recent file, open,
license dialog appears. It’s a tabbed dialog. Then the main cad screen
opens. They both open right away. I see the tabbed dialog open just
briefly and and as soon as the main cad window opens is when the error
window pops up.


(Jeff Lasor) #19

Thanks @mpstek1… Ok I understand what you’re talking about… The tabbed window is known as Rhino’s Splash Screen…for future reference…

Also, did you see my question about your general hardware setup and configuration?


(Jeff Lasor) #20


I just built a Windows 7 machine, updated it with all of the Windows 7 updates, installed the AMD Pro WX4100, along with the exact same drivers you’re using… Installed Rhino V6.3… And it’s working great. No crashes on startup, no crashes at all thus far.

This makes me think that the crashes you’re seeing are very specific to your configuration, which makes it even more important now that you provide all of the details you can about your system and the hardware installed.


(Mpstek1) #21

i’ll run cpu id for you and send the report monday. Should show all the
hardware stuff. It’s a corporate managed machine
as far as Win7/Network. God only knows what I’m using there. One of the
guys I work for built up the PC.
Not sure why he picked the parts he did. I’ve Never had any problems
with any other programs. I have Rhino5 running on it no problems.
I’m a contractor there but I have Admin rights as far as all installs etc.
I have 6 running on my own desktop, loading on my laptop soon.


(Mpstek1) #22


Here’s the detailed CPU-ID hardware report.

Number of monitors doesnt seem to matter I’ve tried it both ways.

MSULL-17.txt (81.6 KB)

(Jeff Lasor) #23

Thanks @mpstek1, I’ve forwarded this to AMD as well… We’re still looking into this one…no answers yet, as we still cannot reproduce the crash on our Windows 7 configurations using and of the AMD cards, including the WX4100.

I will let you know more once we know more.


(Jeff Lasor) #24

Hi @mpstek1,

What happens if you start Rhino in “SafeMode” ? If you go to Windows’ Start menu and scroll down to Rhino’s menu entry, you should have a “Rhino 6 in Safe Mode” entry…(see pic.)

Run that… do you still crash?

The reason I ask is because AMD is claiming that this crash is happening inside their driver when trying to build and use the DirectX shaders that Windows uses for User Interface purposes…in other words, this has nothing to do with Rhino’s OpenGL display pipeline…and more to do with some of the UI elements Rhino uses for its windows and menus, etc… So I’m just trying to confirm this assumption.


(Jeff Lasor) #25


Another thing I’d like you to try… If this is really happening due to UI issues related to Rhino’s usage…then we believe the offending portions of Rhino’s UI are the tabbed panels docked on the right side of Rhino’s main window…

Using the attached file, you should be able to completely remove all panels by replacing the file on your system with this one…

Bring up a file explorer window…
Enter “%appdata%\mcneel\rhinoceros\6.0\settings” in the file location field (see pic)
Place the attached file in that folder, replacing the one that’s already there.

Try starting Rhino

window_positions-Scheme__Default.xml (6.0 KB)