Stutter when selecting leaders and text

I’m having an issue with Rhino 7 - when I select a leader or text object, Rhino pauses for a second or so while the properties panel loads. Has anyone experienced this?


1 Like

run the systeminfo command and post the result please-

For me when I double-click on dimension annotations to get into their properties window there is always a delay of a second or 2 the first time I do so. Sometimes it will never respond to double-click and I have to triple-click. Sometimes double-clicking works immediately. It seems like after I’ve opened properties on a few annotations then it always responds quickly from that point onwards.

sysinfo result

Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15001, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 Ti (NVidia) Memory: 8GB, Driver date: 6-8-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.77
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-8-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Users\jvogt\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\2.0.0\Substance.Win.rhp “SubstanceImporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

I’m curious if you try two things-

disable vray temporarily-

and if you used the game ready driver for your gtx, try the studio driver, and vice versa if you used the studio driver.

let us know if there are any improvements-

when you install the drivers, use the custom/advanced option and use the “clean install” checkbox.

Unfortunately neither of those worked. Is there a flag I can switch so that when I select a text or leader object the properties window stays focused on the object properties rather than automatically switch to text properties? That is where the delay is happening.

Thanks for your help.

boo… ok…

@dale anyideas?

@theoutside - I’m not seeing any “stutter” here to speak of. And my system has lesser specs than the customers. Perhaps load protecting the Plug-ins that do not ship with Rhino and then test again is worth a try?

– Dale

does this happen with all files, or just specific ones? Any imported text in your model? Any font’s not on your system being used?

if you open a clean file with nothing in it, and make a leader, does this behaviour continue?


I first noticed it when working on a file and then started a new one just to test and it happens there as well. Here is a screen capture of the delay. It’s just a brief pause, but when I was annotating a drawing yesterday it became a real issue.


Rhino 7 Commercial - [Top] 2021-08-13 14-18-28.mp4 (3.25 MB)

Any thoughts?

I tried safe mode and have the same issues, I also uninstalled are re-installed and it is still the same. I’m also having an issue where R7 is taking a very long time to mesh, and Pen mode keeps reverting to Wireframe. I’m not sure if these are related.

This may not be related but I’ve seen this type of delay before with either really large collections of fonts on the system or a font that Rhino struggles to read.

Thanks - I just noticed that Arc GIS, which I just recently installed, added a bunch of icon style fonts to Windows.

No luck there.

The workaround is to not have the properties tab selected when working on text or dimensions. I tested this on a Surface Pro 7 as well and it’s the same issue - I can’t believe I’m the only one noticing this.

what graphics card are you using on that surface? is it a standalone card or built in intel uhd?

open rhino and run the systeminfo command, post the result please

It’s an I5 Surface 7, I just wanted to test to see if it was only my workstation. I tried uninstalling again but this time I did a clean uninstall, and nothing really changed. It’s most noticeable when you select a text/dim/leader object and try to pan the view while the properties tab is open there is a noticeable hang, if just the layers tab is up then there is no hang.

Thanks for the help everyone.