Annotations lagging massively on V7

I have a problem where any action performed on an annotation hangs the whole program for 2-5 seconds, even just selecting or deselecting it.

It happens only with my custom template, which worked perfectly fine in V6. Do I need to make a new template file and save it as a V7 3dm? I also have a custom annotation style in that template but the problem is not related to the custom style, because the problem persists with the built-in annnotation styles.

I have disabled all plugins that don’t ship with rhino and freshly installed the latest Rhino 7 version also on my 2nd Windows PC where the same problem occurs.

Here is my _SystemInfo file and my template file:

SysInfo.txt (3.1 KB)

VisualARQ 2 & Lands Design - Meters.3dm (87.6 KB)

Hello - I do not see any delay here but I see there is Vray , Tibidabo and Rhino ART stuff in this file - I do not have any of these installed here, are you certain these plug-ins are disabled when you start Rhino?


I’m pretty sure. I opened a new file and checed that the plugins are disabled. You can see in the command line that the plugin commands don’t work.

I checked again and the issue is there regardless which template I use. Tested on two different windows machines.

Here is my SystemInfo file from my Surface Pro.

SystemInfo_SurfacePRO.txt (2.0 KB)

I just installed Rhino 7 fresh today and uninstalled all old plugins (VisualARQ, RhinoCAM). I also used the default rhino template. Still having massive lags, far worse than on my main PC - about 5-10s for every action.

Hello - thanks, and just to make sure, if you open a new file using no template, does the same thing happen or is it definitively tied to this template file?


Yes. I changed the default template back to the built-in Large Object - Meters.

I also tried opening Rhino in safe mode, but sadly no change…

Here is a gif showing the issue but it’s hard to make out what’s happening.

Immediately afrer I select or deselect the annotation I attempt to pan the view. You can see my mouse moving but nothing happens for a while.

In the bottom left you can see that the cursor coordinates don’t change while the program is hung up.

Also, what’s going on with the grid in perspective view?

That looks like a display driver bug. You should try to update your drivers if at all possible

Steve, the image above three or four posts up shows Rhino in safe mode but VA and Lands menus are present - is that expected?


I just updated to the latest nvidia drivers yesterday. 460.79

Hm… SystemInfo does not indicate NVidia at all as far as I can see.

Standard graphics configuration.
Primary display and OpenGL: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 12-13-2019 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 12-13-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB


Yes, this is the SystemInfo file from my surface pro. In my first post I uploaded the SystemInfo file from my main PC

OK - I see - can we regroup and sort out the main symptoms, regardless of the machine:

Is this correct:

  1. After selecting and dragging (for example) and then de-selecting an annotation, Rhino’s display - view navigation - lags several seconds.
  2. This happens so far in any file, with any annotation.
  3. This happens even when Rhino is started in safe mode.
  4. This happens when all third party plug-ins have been disabled and Rhino closed and restarted.

5. This is all much worse on the Surface Pro.

Does that sum it up correctly?


Correct. Rhino on the surface pro basically becomes unresponsive for about 10 seconds (Not Responding)

I will do a complete windows reinstall in the next days, because i’m getting a larger SSD. I will report if the issue is resolved after the reinstall.

For now, I’m back to Rhino 6 where the issue is not present.

It looks like it’s related to some settings in Rhino. I reset the settings to default by moving the two files in
C:\Users\primo\AppData\Roaming\McNeel\Rhinoceros\7.0\settings and the issue is gone.

EDIT @fsalla : It looks like it’s an issue with the VisualARQ template file.

As soon as I load the default VisualARQ template - Meters the issues begin. Even if I later change the default template to Rhino’s (Small Objects - Meters) and restart rhino, the problems stay.

I guess something gets baked into the settings-Scheme__Default.xml or window_positions-Scheme__Default.xml as soon as one of the VisualARQ templates is opened?

To clarify. Things I have done:

  1. Uninstalled Rhino 6 and 7 and all Plugins with Revo Uninstalled Pro. Deleted the entire McNeel Folder in AppData - Restared PC.

  2. Fresh Rhino 7 install - No issues

  3. Fresh VisualARQ for Rhino 7 install (but not opening the VisualARQ template yet). - No issues

  4. Import old Rhino settings - No issues

  5. Change the default template file to VisualARQ and open new file - ISSUES APPEAR

  6. Change the default template back to Rhino default - THE ISSUE REMAINS

  7. Reset all rhino settings by deleting the two files mentioned above in AppData\Roaming\McNeel\Rhinoceros\7.0\settings - THE ISSUE IS GONE but if i load the VisualARQ template again it reappears.

Here are the settings-Scheme__Default.xml and window_positions-Scheme__Default.xml
files before the isse appears and after. (3.3 KB) (4.1 KB)

Hi @brglez.primoz if this issue was happening when VisualARQ and Tibidabo were not loaded, I doubt VisualARQ has anything to do on this problem.
However, after the fresh Rhino 7 and VA install, you say there are no issues. If you load VisualARQ then (just by running any command), does the issue appear?
Or it’s just when you select a VisualARQ template as default?

The issue starts happening as soon as I open a VisualARQ template for the first time. The biggest problem is that the issue doesn’t go away (even for non VisualARQ templates) afterwards. The only solution is to manually delete the settings files mentioned above.

It looks like that the first time a VisualARQ template is loaded, some settings which cause this issue get baked into the rhino settings file (the settings file size also increases, see example above) and from that point on, the issue is global, regardless which template is being used or if the plugin is loaded or not.

The Before and After setting files I posted above, were copied immediately before and after opening a VisualARQ template for the first time.


The issue goes away when I delete the following lines from the settings-Scheme__Default.xml file
(but it comes back the next time a VisualARQ template is loaded).

These lines get added to the settings file after a VisualARQ template is used for the first time

After a fresh windows 10 installation the issue only appears the first time an annotation is clicked and after that it works smoothly. Maybe installing rhino 7 over rhino 6 causes this?