Rhino 6: Settings continuously reverted back to default

unhandled

#1

Anyone got the same problem, or know a quick fix?
I’ve tried to run as admin, but the issue still persists.

this counts for all and any settings made within Rhino properties…


Rhino 6 for Windows - Evaluation behaviour
Display mode "Copy of Technical" did not keep same settings after a few edits
Command Line Toolbar resets after closing
(Nathan 'jesterKing' Letwory) #2

Hi @BragOn, for starters could you paste the results of the Rhino command _SystemInfo here? Also, do you have your Windows installation set to English, or to some other language - and what Windows version are you running?


#3

Im running Win10 Pro
Version 1709
OS build 16299.192
Language is set to english, but country/region is set to Norway.

Rhino 6 SR1 2018-1-23 (Rhino 6, 6.1.18023.13161, Git hash:master @ 92a80e9e2b29e4670a94deb0d656e234ca1fe036)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GeForce GT 740M/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.65)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Also seems that templates are non-existing within this install… at least they don’t show on startup…


#4

Can you try once to right-click on the Rhino icon on the desktop and “run as administrator” ? --Mitch


#5

Just tried…
Didn’t help. The moment i “accept” the changes, everything just reverts back.


(Nathan 'jesterKing' Letwory) #6

@Brag0n, could you please send me your machine name in a private message? I’d like to search our exception database to see if we have received exception messages from your machine. It could help us pinpointing the problem.

Thank you

/Nathan


#7

So!
Some part of the problem is fixed…

Although “Controlled folder access” was turned off initially,
the solution was to turn it on, then off again…
image
This now allows for changes to not roll back, when Rhino runs…

What issue is left, is upon closing:
this again
Which then reverts the settings anyway.


(Nathan 'jesterKing' Letwory) #8

Wait, so it didn’t work after all?


#9

Exactly.

The difference was that:
Before: It rolled back settings, right away, upon saying "OK" in Rhino options..
(graphically i could see the colors being rolled back to standard. Although this happened for any changed setting)

Now: It rolls back upon closing the software.
(With the error shown above… Which also existed before… I’m guessing it was a two-fold problem… and the error is the last hurdle…)


(Nathan 'jesterKing' Letwory) #10

Well, since changing something in Windows Defender resulted in altered behavior could you try completely disabling Windows Defender for a while? Maybe pull the ethernet before doing so… ^.^


#11

Ahead of you there…
Just tried. No luck this time ;S


(Nathan 'jesterKing' Letwory) #12

Bizarre.

Not sure what else to suggest at this very moment. The problem is clearly very real.

If anybody else has good ideas as what to try don’t be shy, let us know!


(Przemysław Doliwa) #13

I bet rolling back win update would work :wink:


#14

Don’t even go there… :stuck_out_tongue_winking_eye:


(Przemysław Doliwa) #15

I ‘m just sayin’, I had lots of issues after 1709 update including GPU NIC accelerometer fingerprint reader and audio failures not to mention icons and tiles went out and now still some apps dont work as they should…


#16

Well…
Uninstalling Rhino 6 again has removed the error…
But then the initial issue arose again.
rolling back settings, right away, upon saying "OK" in Rhino options


#17
  • Updated to RC3 (problem still persists)

Am I really the only one having this issue?


(foreigner) #18

Try to delete this . then back to run Rhino
image


#19

"this"
Only the uppermost file, or all of them?


(foreigner) #20

Delete these from here then back to run rhino .

image