Rhino 6 Performances Issues

One measurement would be to use the command _PolygonCount with everything selected. Also, with everything unselected, then using _SelAll, the resulting line telling what was selected can be useful.

have you compared your two machines with Holomark?
without actually seeing the file you work on, what it consists of it’s guesswork why you wouldn’t see any performance improvement. But be aware that for Rhino most important for speed is your single core speed, as most things in Rhino are not multi-core. So if your ‘old’ laptop has similar single core speed as the AMD, that could be an indication why.

Ok, I will come tomorrow with an answer for that.

Tomorrow I’m going to compare the two machines with holomark, and come back to you with some more info about size of file, number of polygons and surfaces and specific differences in CPU single core power.
I hope we will figure out more!

Thanks

Hello everybody.

I am back with some info about my files and PCs

The biggest one I am working with is 478MB

  • There are 2076365 quadrilateral polygons and 5510468 triangular polygons in this model
  • 1 point, 7354 surfaces, 914 polysurfaces, 3 extrusions, 1312 meshes added to selection.

This is my SystemInfo of the old laptop:

Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: R39-J

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 (NVidia) Memory: 6GB, Driver date: 12-17-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 460.97

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-17-2020
Driver Version: 27.21.14.6097
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

This is my SystemInfo of the new PC:

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491)

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)
Computer platform: DESKTOP

Standard graphics configuration.

Primary display and OpenGL: NVIDIA GeForce RTX 3080 (NVidia) Memory: 10GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
Accelerated graphics device with 4 adapter port(s)
Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High
Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 10 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino

C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp "Displacement”

Can’t find a link to download the last version of Holomark for Rhino 6 and 7. Any tips? I will post the results here and see if we can figure it out.

thank you!

You’re 15 service releases behind on your laptop. Please update to the latest Rhino 6 service release 6.33, or even get the service release candidate for 6.34. See Rhino Service Release Candidates for information how to subscribe to the service release candidate stream.

Not that bad. The amount of objects is possibly a factor here. In rendered mode I’d expect the display to dynamically downgrade when it gets a bit choppy, but otherwise probably should be ok.

Selection is starting to become a bit slower though, and that doesn’t depend on the GPU all that much.

See this topic, second post: Holomark2_R6

I think your polygon count is fine. I have bigger files in that regard that run smoothly. But as I mentioned before it’s the amount of separate objects that starts to slow down things. 7354 surfaces also means 7354 separate render meshes. Again if your project allows extracting the render meshes of everything you don’t really need to work on and joining those into one object, then deleting the poly(surfaces)
If you can reduce the amount of separate objects by a big margin, I am sure you will see a considerable jump in display performance.

Yes I know, I used to work offline.
But now I am going to drop that laptop and continue working on the new PC, which is weirdly performing in the same way.

Ok, so you are saying that this is not an enormous file and I should be able to work smoothly on it. What I do, but only in shaded viewport. If I switch to rendered it slows down a lot. And if I give a look to the task manager, it tells me it is only using a small percentage of CPU and GPU while chopping in rhino.

The selection looks fine.

I am afraid this is only for Rhino 5. When I install it on the laptop with Rhino 6 it tells me this version is only built to run on Rhino 5. Something similar happens with the PC with Rhino 7.

Smoothly in rendered viewport, with materials, groundplane on ecc.?

I said that I’d expect dynamic downgrade to kick in. Unless you’ve tweaked settings to not dynamically downgrade the viewport.

In a local test scene here with

There would be 22ᅠ987ᅠ944 total triangular polygons in this model after forced triangulation
91 block instances, 17 points, 598 curves, 29346 surfaces, 2359 polysurfaces, 1 linear dimension, 237 texts added to selection.

The viewport is quite smooth. But if I change Tools > Options > View > Dynamic Redraw (Frames per second) to a small value like 0.001 redrawing slows down quite a bit, only 4FPS. For a value 5.0 I get around 19FPS, for a value of 20.0 I get around 25FPS with this particular test scene.

This is on an RTX A6000.

Running the installer just now gives me

image

but indeed HoloMark seems to fail to load. @Holo maybe you want to double-check HoloMark 2 still loads correctly in latest Rhino 6, 7, 8 WIP?

1 Like

4 posts were split to a new topic: Holomark2 fails loading

How can I tweak this one? where is this setting in Options?
Do you mean, by dynamically downgrade, the fact that the shadows disappear? Now the model becomes wireframe-like if I pan around.

With the file in question, running testmaxspeed, I have on the new PC:

  • 3.51 FPS with 5.0
  • 3.50 FPS with 0.001
  • 3.48 FPS with 20
    (it looks really weird to me…)

Now I am going to follow your instructions for Holomark and post here the results.

That does sound weird. But maybe you can share the file confidentially using our uploader https://rhino3d.com/upload?to=nathan@mcneel.com . I’ll get a notification once the upload has been completed. I’ll be able to test and assess better what you’re working with, instead of guessing around.

I assume all your display modes are at their defaults, and otherwise Rhino as well. (Tools > Options > View > Display modes - for each mode select it and ensure you restore the defaults).

I was wondering, might it be the reason that everything is messed up that I am using an evaluation copy of Rhino 7?

All my display modes are at their defaults.

What is weird to me is that if I go on the rendered viewport and pan rapidly around, my CPU works only at a maximum of 6 7 %, while my GPU doesn’t work at all (which I understood is ok for rendered mode). Then, if I switch to Raytraced, it works a lot better than my old laptop, and almost the same as Rendered. Anyway, whatever I select in Options to cycle with the CPU or GPU, in the task manager they never go over 10%.

That would be awesome and really appreciated, I would just need you to sign an NDA with my company. Can we do that?

No, the evaluation version is a fully functional Rhino version (for the duration of the evaluation period).

One thing I was thinking about is what driver you are using: game ready or studio driver? If you’re on the game ready driver you may want to try the other version.

You may want to do a clean driver install as well. When installing the driver select the clean install option.

I’m not sure if you’re looking at the right graphs. In the task manager for your GPU you need to ensure you look at the CUDA graph, not the 3D.

During the HoloMark2 run I watched the 3D graph for the viewports and depending on the GPU test utilization was between 20% and 100%.

We don’t sign NDAs, sorry.

It’d be useful if you could create a new file that shows similar behavior, but is not under NDA.

Perfect, so I will do a Holomark test with the driver I have now (game ready) and later on with the studio driver so I can compare the results.

I don’t get it. I should look at the CUDA graph (I did not know it!) but during your test you watched the 3D graph?

I did suspect it. I am sorry I had to ask. I will try to do something like that. Not sure I can manage to upload it soon though.

CUDA graph you look at when using Raytraced. 3D graph for the other modes.

This also if CPU is selected in cycles options?

No, in that case just check CPU utilization. With complex scenes you’ll see some 3D utilization as well because a stripped down version of rendered mode is always drawn on each viewport refresh done by Raytraced.

K, tomorrow I ll post some screenshot of the task manager too

Hello guys, I found some time to do some other tests. I would like to share the results with you to know if you see any weird things in my setup.

First, this is the Holomark test I performed (thanks to @Holo who helped me get a numerical result from it). I compared it with others on the topic and it looks really good to me in terms of raw score.

These are my CPU and GPU during Holomark.

2

Here, my GPU dealing with arctic with scene lighting, sharp shadows, sunset lights.

1

Everything is working fine, it seems really better than my old laptop, I am able to do things I couldn’t in the past.

My only concern is that I am using only a small percentage of the total power of the PC. It never hits >60%. Sometimes Rhino lags while doing things and in the meantime the CPU is at, let’s say, 5% (same with GPU operations).
Is it Rhino the bottleneck of my system? Or I can improve somehow the performance of it?

thank you guys!