Rhino 6 only opens on Safemode

Hello. I use Rhino 6 for furniture modelling, and usually i have no problem with it. I’m not sure about the reason behind it, but last time i tried to open a 3dm file (that was working fine previously), Rhino would crash my computer. I booted it again, and the program started as it normally would. But that’s where the problem starts: Everytime i try to open any 3dm files, rhino 6 crashes. And when i tried opening a brand new file, the program would behave like if it was on safe mode (lines would not be visible, anything i constructed within the program would only be visible in modes like Render, Artistic, Pen, and on Shaded, only the “volumes” would be visible), even though the system’s info tells otherwise.

I updated my graphics card using AMD Adrenalin Software (a software similar to NVIDIA’s launcher, that you can use to open up apps and games) and there Rhino 6 is listed as Rhino 6 In Safe Mode. The problem is, i reinstalled Rhino 6, updated my graphic drivers, executed it on Administrator mode, but nothing has worked, the program still opens in safe mode and crashes whenever i try to open previous 3dm files. The strangest thing is that in AMD Adrenalin (a software similar to NVIDIA’s geforce experience) the rhino 6 software is listed as in safe mode regardless of how i try to start it. I also use Blender and Sketchup on the same computer and all of them are working just fine.

My Rhino 6 only opens in safe mode regardless of how i try to open it. It crashes every time i try to open almost any type of 3dm files. Already tried to reinstall and run on administrator mode, to no avail. I would like to know if there’s a way to correct this. I also use Sketchup and Blender, and there’s nothing wrong with them. I need the program working properly in order to work. I would gladly appreciate any help!!

My system info:
Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-OEK4C2V

Non-hybrid graphics.
Primary display and OpenGL: Radeon RX550/550 Series (AMD) Memory: 4GB, Driver date: 4-20-2023 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 4-20-2023
Driver Version: 31.0.14051.5006
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 11964 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I’m wondering if the AMD driver disease has become contagious to Rhino V6… For months now, AMD has screwed up their drivers to the point where nobody can recommend them anymore for use with Rhino. Most of the reports have been for V7 however.

If you open Rhino in safe mode and go to Options>View>OpenGL and uncheck GPU tessellation, then restart Rhino normally, does it help any?

Unchecking GPU tessellation seems to have done the trick! I was unware of this disease plaguing AMD’s drivers. Anyways, thanks for the help Helvetosaur. I hope this error never pops up again.

Hi Peter -

Apart from the AMD driver issue, you appear to be way behind on your Rhino version. I’d look into updating to 6.35!