Rhino 6 - Not responding when toggling OSnaps

Hi, I’ve set Rhino 6 Eval up on on a new laptop. General modelling and performance seem fine but I’ve noted the following issue.

When toggling with the Grid Snap, Ortho etc. through to Gumball, Rhino goes to not responding:
blue circle turning, whited out window and Not Responding in the title bar.
After ~1min it recovers OK.

image

The same happens when checking (or unchecking) an object snap. eg. End, Near etc.

System info below:

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Evaluation, build 2019-12-17
License details: Cloud Zoo. In use by: Paul Harley ()
Expires on: 2020-04-05

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: LDS-PAULH14

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro RTX 3000 (NVidia) Memory: 6GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version: 26.21.14.4166
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\import_STEP.rhp “STEP Import”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - nothing jumps out at me in your system info… what happens if you undock the OSnaps and just float it over the modeling window - does that make any difference in interacting with it?

-Pascal

Hi Pascal, thanks for replying. I tried undocking the OSnaps to a floating menu over the modelling window and confirm that the issue is still there.

None of the other menus or tabs cause the issue. Also note that the Record History toggle functions fine.

Paul

@JohnM - Do you have an idea what to check here?

-Pascal

I’ve just noticed now that if I’m mid command - i.e clicked to make the 1st point of a line but not excuted the end point yet. Then the toggles work fine. It’s only when I hit enter to execute the end point that the hang happens.

Hi Paul - by your last comment, do you mean that toggling is quick and painless if you toggle inside a command? And does the spinning donut not happen at all in this case, or does it happen, but only after the command ends?

Also, does it make any difference if Gumball is on or off?

-Pascal

It still happens but only after the command ends. Whilst in the command they toggle fine.

No difference with Gumball on or off.

OK - thanks - do you have any ‘productivity’ utilities running in Windows? What other apps are running? Unusual monitor setup? Right now we’re at a loss… even the bigger brain I’ve asked is scratching his head on this.

-Pascal

Oh dear, it is strange. I did have MS Outlook, Powerpoint and Teams, plus Firefox.
I’ve just tried with only Rhino open and the startup file and the issue is still there.

I have 1 monitor via a dock. I’ll check if it happens when undocked next.

It’s the same when undocked and using only the laptop screen.

Can you try this:

  • Close Rhino
  • Open Windows File Explorer
  • Navigate to “%APPDATA%\McNeel\Rhinoceros\6.0\settings”
  • Rename the “settings-Scheme__Default.xml” to “settings-Scheme__Default.xml.disable”
    Then restart Rhino and try again.

Jackpot! Working as normal with that .xml disabled.

So is it something in the custom settings I have applied? I did bring those from Rhino 5.

Paul

It’s hard to say, can you send me the “settings-Scheme__Default.xml.disable” file so I can have a look?