Osnap not working

I downloaded the Rhino7 evaluation version today, and the command Onsnap is not functioning at all. Whenever I click it, the windows change size a bit as if I zoom in or out, but the command itself does not activate. This makes it incredibly difficult to do anything.

Hi @user1144
First thing to do is to run the command SystemInfo In Rhino and copy/paste the resulting text here - that’ll give us an idea of what might be wrong. Under-powered graphics card or graphics card drivers that are not up-to-date (or both!) is my first guess :grinning:
HTH, Jakob

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Evaluation, build 2021-11-09
License details: Stand-Alone
Expires on: 2022-02-14

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 7.9Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 620 (Intel) Memory: 1GB, Driver date: 10-14-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: AMD Radeon R7 M440 (AMD) Memory: 4GB, Driver date: 1-18-2021 (M-D-Y). OpenGL Ver: 4.6.14758 Compatibility Profile Context 21.1.1 27.20.14527.2002
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 1-18-2021
Driver Version: 27.20.14527.2002
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

For the record, I did not have this issue with previous versions of the program.

Hello- please try running testResetWindowPositions then close and reopen Rhino - my guess is the panel is opening, but off screen, or partly off screen, and you cannot get at it.

-Pascal

Thank you! It’s working now.