Rhino 6 not printing shadows as seen in preview


I have an issue since the end of February some time with not being able to print full shadows and shading in rendered view from layouts from my desktop. The shading appears on the screen and on print preview but does not print/save as PDF which comes out as cartoonish - there are some shadows but not on solid faces (I can’t really identify what exactly is missing - ambient?).

I have checked back and this was fine up till at least 25/02/22. I upgraded to Windows 11 at the beginning of the year so this can’t be the issue. The shadows still pdf correctly on my laptop running Windows 10. I have exported an ini file for rendered from the laptop an installed it on the desktop but this does not help.

I have updated the driver for the NVIDIA GPU and the Intel integral graphics card which as had no effect. I have repaired the installation of Rhino to no effect.

I have spent hours changing settings to try an produce shading and contrast in the views but comparing with previous exports it is clear that something is not printing no matter what is set up.

Can anyone identify what has happened and how to fix it please?

Thanks very much.



Sysinfo below:
Rhino 6 SR35 2021-8-10 (Rhino 6, 6.35.21222.17001, Git hash:master @ 073ac7b225c67348731c6597127b9410126c3139)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo. In use by: ianjlove ()

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-7U1KEPV

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 6-1-2021 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 4-20-2022 (M-D-Y).
> Accelerated graphics device with 1 adapter port(s)
- There are no monitors attached to this device!

There is only one monitor detected, but it’s connected to the slower, integrated graphics video port.

  • Recommended: Unplug the monitor and plug it into one of the video ports on this device:
    [NVIDIA GeForce GTX 1050]
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 6-1-2021
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\export_PDF.rhp “PDF Export” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

System Specs are as follows:

Device name DESKTOP-7U1KEPV
Processor Intel(R) Core™ i7-8700T CPU @ 2.40GHz 2.40 GHz
Installed RAM 16.0 GB (15.8 GB usable)
Device ID 07F14C08-0C0A-4C49-9276-BE41E29B4F2A
Product ID 00325-81228-74147-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch Touch support with 10 touch points
Edition Windows 11 Home
Version 21H2
Installed on ‎17/‎01/‎2022
OS build 22000.739
Experience Windows Feature Experience Pack 1000.22000.739.0

This is the pdf output I obtain now.

This is how it should look, does look when output from laptop, and used to look from PC.

This is the print previews on PC

Hi Ian -

Your PC somehow got configured to use the integrated Intel GPU for OpenGL drawing.
Have you tried that recommendation?

Thanks for your reply.

It is an integrated PC so the monitor is not plugged into anything. My laptop only has an integrated intel graphics card (surfacebook) and the pdfing works fine (but I do not want to keep having to transfer to the slow laptop to produce work).

The Rhino graphics profile is always set to Power Saving which I do not understand but I don’t think it is related to the shadows issue as this has always been the case.



Have you tried printing as raster and not vector?
Maybe the combination is confusing your system.
And try lowering the dpi from 600 to 300, maybe that too is overloading the graphic memory or something.

I have now uninstalled Rhino and removed all local files, appdata, programdata, etc and reinstalled which has solved the problem. I don’t have any idea how it was caused however and no settings changes had any effect.

For the record the issue was not printing ambient shadows from layouts. Sun shadows printed from layouts and ambient and sun printed from viewports to pdf. It applied to all display modes - eg if Arctic was used in ambient occlusion setting then the image pdf’s as a white outline with no shading or ability to see objects (this was tested on layouts otherwise completely blank).

It is obviously not ideal to reinstall in this way and lose all my set up, so it would be good to know how to avoid this happening again.