Problem with printing PDF - shading switches off

Dear Rhino team,

I have a strange problem that occurs when I want to print on my work machine.

When I print on my laptop (Microsoft Surface Book 2) - the shading is there as seen in the viewport, no problem with PDF print and the result looks fine. See here:

Then I had to print the same file on my work machine, and the preview looks ok at first. But when I print it to PDF, all shading switches off. See here:

After that, the shading (arctic) is not working anymore. I tried to change the shadow color, GPU tessellation, Flat shading, hiding objects etc. But I can’t get the shading to “kick back in”, also in viewports. The only thing that works is restarting Rhino.

Please help.


Hi Pawel - on your work machine, could you run the Rhino SystemInfo command and copy-paste the result here?

Hi Wim,

Here it is:

Rhino 6 SR24 2020-3-10 (Rhino 6, 6.24.20070.23271, Git hash:master @ f86f6e5421b3f7d19029a9e7eabd421ddd313111)

License type: Commercial, build 2020-03-10

License details: Cloud Zoo. In use by:

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)

Machine name: PAWEL-THST

Non-hybrid graphics.

Primary display and OpenGL: NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 1-29-2020

Driver Version:

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 8 GB

Rhino plugins

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20070.23271

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”

C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”

C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.24.20070.23271

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.24.20070.23271

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.24.20070.23271

C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”

C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.24.20070.23271

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20070.23271

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Wim,

Do you have any ideas what might be wrong?

1 Like

We’ve had a few issues with printing arctic mode that I thought have all been fixed, but this could be a new one to us. @DavidEranen or @andy could you please follow up on this to determine what the problem is? I created a YT issue for this at

1 Like

Hi Steve,

Thank you for the response. It is really crucial for me. Meanwhile, is there an easy way to revert to older service release? Or should i just uninstall rhino and install again with older SR?

Have a nice weekend!

I can definitely send you a link to an older SR. So this worked in the past? Do you know what SR this worked in?

It worked before, yes. I don’t know which SR so I will revert to SR 6.23 (it is still in the cache folder pointed out by Pascal in another thread).

The problem is that since it printed out fine, there has been a Widows update, Rhino update and GFX drivers update. So it is difficult to know, what made the problem. Just wanted to start troubleshooting with Rhino, and check if older SR solves the problem for time being.

Also, I tried to print with other shading options, and I get weird results. I will come back with it tomorrow when I am at my work computer.

1 Like

Ok, if you determine that 6.23 fixes the issue I would like to know. If you are willing, with your help we can narrow in on exactly what caused this bug in 6.24 to quickly fix it going forward.

Hi again,

So a small update.

Reverting to SR 6.23 and 6.22 didn’t solve the problem. I have updated graphics driver to the newest available. I have checked and unchecked “GPU tasselation” and antialiasing settings in all configurations. Also, I have adjusted the settings in nVidia panel. Nothing works.

To add, I did some printing tests (Vector and Raster mode produced the same result):

A1) Rendered mode with AO shading before print:

A2) Rendered mode with AO shading after print:

After that there is no AO shading in the viewport.

B1)Rendered mode with normal shading before print:

As you can see, printing dialog is already without shading.

B2)Rendered mode with normal shading print in pdf (shading in rhino is fine)


Nothing printed except curves.

D) ViewCapturetoFile - no problems, even with 8000x8000 resolution. Shading doesn’t switch off.

It all happens on a machine with GeForce RTX 2070 Super. But on my laptop (GeForce GTX 1050), everything is fine…


I can’t reproduce this on my end. Do you think it would be possible to send me a file which exhibits this problem? You can send it privately through this link:

If you don’t want to send a file, then can you create a simple file from scratch which has only a sphere? Does it still not work?


Hi David,

I was afraid of that… When I am creating a file without template, it also happens. Viewcapture to file works fine in both modelspace and layout.

I have sent you the file.

@pawel Thanks for the file. Unfortunately I can’t repeat it with the file either.

Could you try the following?

  1. Close Rhino.
  2. Navigate Windows Explorer to: %APPDATA%\McNeel\Rhinoceros\
  3. Rename the 6.0 folder to 6.0.backup
  4. Start Rhino and try to reproduce the issue.

If you want to get your settings back just close Rhino, delete the 6.0 folder and then rename your 6.0.backup folder to 6.0.


Hi David,

I have done what you asked (except the folder structure looks like this:

The problem is still there. Also, Rhino settings looks the same…

Gah, I gave you the wrong path @pawel. It’s %APPDATA%, not %TEMP%. I have updated the path in my previous post. Please try it again.

Hi David,

Now it works! Also when I import the view template (and nothing else). But as soon as I import all options, it goes back to being a problem. I have uploaded it as a *.ini file.

Also, the same behaviour as mentioned above is occurring in Rhino 7 WIP. Just wanted to give it a try.

@pawel When you say “View template”, do you mean “Display mode”? You sent me a display mode which is a Wireframe display mode. It doesn’t show any shaded objects for me.

Did you send the wrong display mode? Can you send me the display mode which you are using when you are printing the PDF.


Hi again,

Yes,sorry - I meant Display mode.
Lets break it down:

  1. I rename the folder and start “Fresh” rhino. I set the Display mode to Arctic - Everything prints fine.
  2. I import the Display mode “Hidden line with AO.ini”, switch it on - Everything prints fine.
  3. I use OptionsImport to load in the “PJT all settings.ini” - It is broken again.

I have sent you the files again.

Hi @pawel,

When I use your display mode, my sphere looks like this:


In Arctic mode it looks like this:


It looks like I’m reproducing the bug already with your display mode, do you agree? I will continue looking at this issue tomorrow - thank you for your patience and for the help!