Rhino 6: Mapping created, but not visible?

Hi @BrianJ,

I like your tutorials very much, they have a relaxed and very informative style:

I try to map the material, but I just see the placement, when I activate the widget in Rhino 6.8:

Is this a Rhino bug?



1 Like

Hi Michael,

Thanks. My first thought was that ‘advanced texture preview’ might be disabled in the Rendered display mode on your machine but I’m unable to reproduce the issue here turning it off in my own settings. Can you post the 3dm and your system info from the Rhino 6 help menu?

Hi Brian,

sure: holz_bogen.3dm (454.7 KB)
system.txt (1.6 KB)

Perhaps it has to do with switching in the material from WCS to chanel 1. BTW, do I have to save the material after switching, or is it saved automatically with chanel 1?



Thanks for the 3dm… I don’t see the issue here opening your file. Let’s try two things, first restore the Rendered display mode to the defaults using the button for that mode in Options>View>Display Modes>Rendered.

Then, if that doesn’t help, would you be willing to try a graphics card driver update? Yours isn’t that old but it may be the cause.

The 3dm when saved will save the material’s settings and mapping. If ‘save textures’ is checked in the save dialog the texture is also embedded in the 3dm.

Hi Brian,

I’ve resetted the view settings and updated to the latest graphics driver. No change.

system_nvidia_driver_updated.txt (1.6 KB)

Here again, the problem:

I’ve also noticed that the material size jumps from 100 to 0.001, when switching to chanel 1. What do you see? Perhaps this is a bug in the local windows system. In Europe we use commas for number fields:

Perhaps someone can test this on an European windows?



@andy @DavidEranen Do either of you have any ideas on what might be causing this on Michael’s system?

@BrianJ I can reproduce the bug in 6.7 and 6.8. I can’t reproduce it in 6.x (the very latest). Can you verify this to make sure I’m not missing something here?


@DavidEranen, I’m not 100% sure what I’m looking for here…
From the video’s that are posted, it would appear that the gumball is lacking in the one that @Michael_Meyer posted, whereas it shows in the one that @BrianJ posted. Is that the issue?

If so, Gumball is not enabled on Michael’s system:

The problem can be seen in the first video that the user recorded. The sphere mapping doesn’t show up in the viewport until the user clicks the Show Mapping Widget button. When the mapping widget is hidden, the viewport reverts back to the wrong mapping.

Thanks for the clarification, @DavidEranen.
I can see the problem here on 6.8 - and can confirm that it is gone in 6.9.18239.

1 Like

@Michael_Meyer I just messaged you a link to test an internal 6.9 build to see if that also solves the issue on your end.

1 Like

Hi Brian,

Rhino 6.9 fixes this problem.

Thank you very much


1 Like

UV editor 6.9.18239:

‘Glanzlicht ausgewählt’ doesn’t work at all.
BTW, this is a funny term.
Perhaps better ‘Auswahl anzeigen’?

On Apply:
Unbekannter Befehl: Y
Änderungen anwenden ( Ja Nein ):

And the 2 buttons are not aligned.

Did this work for you in a previous version? @BrianJ / @DavidEranen, any ideas on this one?

The localization issues is something for @Joachim_Kuntz to take a look at.

Nice one, @Charles: ‘Glanzlicht ausgewählt’ is definitely wrong. I’ll change it for ‘Auswahl hervorheben’. Thank you for your suggestion.

@Charles Thanks for the report of ‘highlight selected’ not working for you. I just tested this here in 6.8 and 6.9 and both worked as shown in my attachments. Can you check that Rendered mode is set to the defaults and then if the problem persists provide your system info from the Rhino 6 help menu? Thanks.

Restoring ‘Rendered’ to the defaults healed it.
Now it works.
Thank you.

You’re welcome. I also just filed the gamma issue with the texture display in 6.9 in case you noticed that too… thanks for making me see that! https://mcneel.myjetbrains.com/youtrack/issue/RH-48084