RH6 material & texture mapping problems

I’ve been taking weekend Rhino classes geared to my industry. I am the only person using Windows RH6. The instructor and one other are on Windows RH5, and the rest on Rhino for Mac.

During the most recent class, adding textures and mapping gave me no end of problems. Many processes did not work for me. Here are some of the problems I encountered:

  1. Distortions of the floor texture. This was simple drag and assign process. This is how it displayed in various views. (See pics)
    Render view.

In the Render window or Raytraced. See what happens to floor texture!

  1. I tried several methods to rotate or resize textures (The wood especially) to suit directions. None worked for me. Though others in the class succeeded. (We’re modeling the same thing.) Initial view in Render.

    Change rotation-any. No result.

  2. Texture mapping did not work and gave odd behavior. Changing position and/or rotation made no difference.
    If I entered a a number in XYZ size (e.g. 100) and clicked X=Y=Z all the slots would change to some other number like 34.667. The Mapping Widget did not work.

  1. The back window is translucent in render mode, but Raytraced or in the rendered it is not. I have not switched off environment in this. Capture.

  2. I would drag a texture to an object, and it would be applied to another object somewhere way off. (I wondered if that was pointer/mouse problem) But there was no problem with the mouse pointing in other command/tolls.

  3. lots of crashes! I’m uploading the model after the last crash. I recovered it but it doesn’t look the same. The floor texture is changed and the windows are not longer translucent.

Link to model

Thanks for the report of what you’re seeing. The file you uploaded as you mentioned in #6 does not appear to be the exact same as the one you show here so that may account for some of the differences I’m seeing…

I did not have the image texture in the material assigned to the floor (like you said), so I grabbed the same material from the material library and applied it to the floor. I get the same mapping in Rendered view and Rhino Render. Can you choose System Information from your Help menu in Rhino 6 and return that text in reply here? Maybe that will provide some clue as to why you get something different.


Something does seem off about that object, do you recall how you made it and if you had assigned any other mapping methods to it at some point? I can’t figure out how it got like this so far but the fix is to Explode and the Join it back together, this refreshes the surface mapping. Then If you leave it on surface UVs, I’d change the rotation in the Material panel instead of Properties>Texture Mapping.

If you used another mapping method in properties for the object like Box, you can use the rotation fields there but I’d also use the UVW rotation at the bottom of those settings. I’m not sure why those fields for XYZ rotation are exposed when Surface mapping… @andy Can you explain what these should do with surface mapping?


Those settings again may not be doing the correct thing when surface mapping is used, I’ll file something for the developers to look at to be sure. If you use Box or Planar mapping these would have an impact.


The issue was that you had the glass material set to frosted. Raytraced and Rhino Render calculate refraction so they showed the material with this setting but Rendered display mode does not.


Check your Windows display scaling setting, I wonder if it is on the recommended setting for you display. The version of Rhino 6 may also be a factor here, let me know the system info from #1 pls.

6 -

Have you been getting crash reporters that pop up and have you sent those in from the same email you’re using here?

Sorry you had so many problems, thanks for the reports. Hopefully your system info and any submitted crash reports will give us more info to know why.

Thanks for the quick response. I’m work on my Desktop at present. I’ll try to get the info from the Surface later.

Only once do I recall the crash report dialogue popping up. I did chose send.

Sysinfo. However, I don’t know if this is valid for the e problem. I started the project on 6.6 and it updated to 6.7 after.

Rhino 6 SR7 2018-7-18 (Rhino 6, 6.7.18199.22081, Git hash:master @ 123fa928529aea2697d4d286dda5f63a029d2a71)
Licence type: Commercial, build 2018-07-18
License details: Cloud Zoo. In use by: CalypsoArt ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-AKCCHM8

Intel® Iris™ Graphics 540 (OpenGL ver:4.4.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build
Driver Date: 3-9-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18199.22081
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18199.22081
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18199.22081
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18199.22081
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi again,

Thanks for the system info. I am not finding any crash reports from your email address in our system to hopefully learn more about the crash you experienced and sent the report in from. I searched using the email address on your Discourse account. Do you recall adding your email address to the report and did you use that same email address?

Regarding your system info, I wouldn’t personally choose that GPU for 3D CAD work but I know one of our developers has the same one with that same driver and can run Rhino 6. They likely aren’t doing the same things you were though.