Rhino 6 german: rendered viewports without material

unhandled

#1

Hi @pascal,

my customer doesn’t get the material preview in rendered viewports.

What to check?

Thanks

Michael
www.flexiCAD.com


(Pascal Golay) #2

Hi Michael - here’s what comes to mind -

  • is the rendered mode default?
  • does a full render show the materials?
  • can you verify that the material is actually applied to the objects - either via layer or object assignment?
  • I guess there could be blocks involved though this looks like quick test objects and probably not a block but that would make a difference.

-Pascal


#3

Hi Pascal,

is the rendered mode default?

set by viewport conext menue, I think. Why?

does a full render show the materials?

I will ask

can you verify that the material is actually applied to the objects - either via layer or object assignment?

Yes, the material is applied, you can see this in the material name in the properties.

I guess there could be blocks involved though this looks like quick test objects and probably not a block but that would make a difference.

I don’t think so, it looks like a simple sphere and box.

Hm?

Thanks

Michael


(Pascal Golay) #4

Hi Michael - I see a material exists in the material panel but I do not see the object Properties in that image.

-Pascal


#5

Yes, the material preview is also faulty.

Michael


(Nathan 'jesterKing' Letwory) #6

@Michael_Meyer the intent of the question here was if the Rendered mode settings have been changed. Ensure that by going to Tools \Rightarrow Options \rightarrow Views and ensure that Rendered display mode is reset to default completely.


#7

Hi Nathan,

ah, OK, I understand.

Nethertheless, the material is also not showing in the properties/material panel, as you can see in the picture.

Thanks

Michael


(Nathan 'jesterKing' Letwory) #8

Can you share this scene with this specific material?


(Pascal Golay) #9

Also, Michael - can you also find out the SR the user has? I seem to recall that there was a bug in some languages related to the render material previews.

-Pascal


(foreigner) #10

No problem in my Rhino

image

try to share that scene .


#11

Hi @pascal and @nathanletwory,

here are the files: Systemdaten.txt (1.5 KB)

Versuch rendern.3dm (338.7 KB)

Thanks

Michael


(Pascal Golay) #12

Hi Michael - thanks, that is more recent than the bug and fix I was thinking of.

-Pascal


(Nathan 'jesterKing' Letwory) #13

As far as I can tell the behavior here is as expected: the bitmap texture image file is missing - the placeholder texture is a single white pixel.

I wonder, does your user have only de-DE installed? Does it start working once the user also installe en-US (but can still keep the Rhino interface in german).

/Nathan

P.S. when creating files that are intended to be shared it is probably a good idea to always check Save Textures in the save dialog.


#14

Hi @Nathan,

I can’t answer your questions.

But I have tried with the customer to create a user defined material and add a color texture here:

And the texture also didn’t show up in the rendered viewport.

Cheers

Michael


(Nathan 'jesterKing' Letwory) #15

Note that in your last screenshot the texture won’t show up because the checkbox for the color map isn’t checked.


#16

Hi @nathanletwory,

yes, I know. This picture is from me and not my customer, just to show you, that this doesn’t also work, when a texture picture is selected and (of courese) activated.

Thanks

Michael


(Nathan 'jesterKing' Letwory) #17

The reason I asked earlier about language package is that the 3dm file you attached has a german-language material, but the texture path is for en-US. Maybe @andy should have a look, too.


#18

Hi @nathanletwory ,

can you help, what should I ask the customer? I hope my customer is also looking in this discussion.

Thanks

Michael


(Nathan 'jesterKing' Letwory) #19

@Michael_Meyer,

You could ask your customer to modify the Rhino installation. In the installed programs manager of Windows select Rhino 6, choose to modify. Make sure the English language package is selected as well as the german, confirm.

Once the installation modification has completed Rhino might want to reboot the machine, probably a good thing, just to be sure. Then start Rhino and make sure UI language of Rhino is still set to German. Once done see if the materials now work.


#20

Hi…,

I have found the problem. Rhino had no internet-connection. After connecting to the internet and loading all textures at once with the command BibliothekTexturenHerunterladen it was working.

Thanks

Michael