Material, mapping etc

unhandled

#1

@Brian

I know this video, as seen in this post:

I tried to do the same in V6 Work In Progress (6.0.17101.6541, 11.04.2017).

Rendered view:

Nothing to see in Rendered view.
Ok, this seems not to work right now.

So I tried to get some mapping in the Raytraced view.
Raytraced view:

Exactly nothing happens.
I do exactly the same steps as seen in the video.

Also the Materials panel looks not good:

Thanks,
-C-H-A-R-L-E-S-


(Brian Gillespie) #3

Thanks, @andy knows best about how all this is supposed to work. This looks like a bug to me.


#6

In WIP (6.0.17108.11571, 18.04.2017)
it looks better, but still quite different in Libraries and Materials tab:

Also the material is not visible at all in Rendered view:

-C-H-A-R-L-E-S-


(David Eränen) #7

Hi @Charles,

Thanks for the reports. I created two new YouTrack items (RH-39000 and RH-39001).

By the way, what happens if you rotate the view after applying the material and it shows up black? For me it looks good after forcing the view to render another frame.


#8

Hello David,

No change regarding the texture.

-C-H-A-R-L-E-S-


(Brian Gillespie) #9

RH-39000 is fixed in the latest WIP


#10

@Brian
Still the mapping doesn’t work in here.
I get some texture on the object, but regardless what I do, no effect.
In V5, it works as expected.


(Brian Gillespie) #11

Yes, RH-39000 got reopened shortly after this post; we’re still planning to get it fixed.


#12

Brian, from what I understand, RH-39000 is not about the mapping functionality.


(David Eränen) #13

@Charles I’m unsure exactly what the mapping problem is. Can you give step-by-step instructions to reproduce?


#14

Hi David,

the mapping doesn’t work AT ALL.

Try to do the same as in the video mentioned in the initial post.
In V6, it just doesn’t work.
At least no for me.

Of course I can make a video of non-happening things in V6.
But there is not so much to record…

Charles


(David Eränen) #15

@Charles In order for the Box mapping to have any effect you need to set the Bamboo texture to use a mapping channel (not WCS Box which is the default for Material Library materials).

Does that help?


#16

No, I’m too stupid.
If you could support me with a very simple example (video), that would be great.


#17

Finally I have mapping working in principle.

Puh, how complicated and misleading it is.
How should I know that I have to select multiple mapping channels if I want to use a single one only?
That is far too complicated.


(David Eränen) #18

@Charles

There is only ever one mapping channel active for a texture.

Mapping channel 0 uses the texture coordinates on the object itself (surface parameters).
Mapping channel 1 uses whichever mapping that is set to channel 1 (in our case, the box mapping).

It is possible to have many mappings on a single object, all in different mapping channels.

The Bamboo material wasn’t using any mapping channels, instead it was set to WCS (box). That can be a bit surprising and unexpected, since new materials default to mapping channel 1.