Rhino 6 Keeps freezing on my machine

unhandled

#1

I am runing Rhino 6 on a new computer on which I don’t have a GPU installed, yet.
Rhino freezes when I change to render display mode with a dense mesh and when I make a displacement.
Is this a normal behavior due to the fact that rhino 6 needs a video card to make those tasks? Can I damage the CPU if I work without GPU? I am planing to install a GTX next week.

My system right now:
Intel core I7-4790 3.60 GHZ
8 GB RAM

Thank you!


(Wim Dekeyser) #2

You probably have an Intel HD GPU installed on the motherboard. Run the SystemInfo command in RH6 and paste the result here. Check if there are updated drivers for the card and install those.
Also, does unchecking the setting for GPU tessellation in Rhino Options > View > OpenGL help?


#3

@wim his is what I get:

Rhino 6 SR0 2018-1-16 (Rhino 6, 6.0.18016.23451, Git hash:master @ c0b115e88c59340755c25f7822e172c79c9b530b)

Windows 10.0 SR0.0 or greater (Physical RAM: 7.8Gb)

Intel® HD Graphics 4600 (OpenGL ver:4.3.0 - Build 20.19.15.4835)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 20.19.15.4835
Driver Date: 10-16-2017
Driver Version: 20.19.15.4835
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

I think I already have latest drivers. I checked with Driver Booster 5 app. But I am not 100% sure If that app works fine. How can I be 100% sure?

Now Rhino works better but I have the feeling that it is still slower than rhino 5. Will It work better when I get a GPU?


#4

I would like to understand the importance of the GPU when working in rhino. How does it affects the performance?


(Wim Dekeyser) #5

Why would you want some ‘booster’ app to check for driver updates. Sounds spooky…

What changed?

You will be able to handle larger files more easily.
Not sure if @stevebaer has a list of OpenGL goodies that are turned off when you e.g. turn off GPU tessellation.


#6

Updated the drivers and rhino stopped freezing on every single file. On the other hand, as you told me, I am having unstability problems with files larger than 1 Gb due to the lack of a dedicated GPU.

Thanks!