Rhino 6 crashes with no reason in random timing

Hi My Rhino 6 always crashes and stop responding when I am using this normally.

My System Info

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Educational, build 2019-08-23
License details: Cloud Zoo. In use by: Chi Chun Tang ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-IT1M95B

Hybrid graphics system.
Primary display: Intel® HD Graphics 520 (Intel) Memory: 1GB, Driver date: 9-26-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 965M (NVidia) Memory: 2GB, Driver date: 4-4-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 391.40

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-4-2018
Driver Version: 23.21.13.9140
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Any way to solve ? Thank you

I would start by updating both your video card drivers…

Sometimes it is difficult to update the Intel HD driver, see this thread for a procedure in that case.

Hi Helvetosaur,

Thanks for your advice.
I tried the method and it worked for awhile ( maybe just I was lucky in that moment)

But now it becomes the same. I don’t know it is my Rhino 6 problem, Window 10 problem or my Surface Book problem. ( I want to throw away this laptop a lot)

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Educational, build 2019-08-23
License details: Cloud Zoo. In use by: Chi Chun Tang ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-IT1M95B

Hybrid graphics system.
Primary display: Intel® HD Graphics 520 (Intel) Memory: 1GB, Driver date: 8-23-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 965M (NVidia) Memory: 2GB, Driver date: 9-5-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 436.30

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-5-2019
Driver Version: 26.21.14.3630
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”