Rhino 6 grasshopper install fails

A friend of mine is using Windows on mac thru boot camp, they’re planning to upgrade to rhino 6 from 5.

But when they install rhino 6, grasshopper doesn’t work.
It give this error when launching gh

And when gh opens, all the ribbons are blank.

In assuming it’s because it’s missing files for some reason, so I’ve tried copying my grasshopper folder in %appdata% to their computer, but still the same problem.

I’ve tried reinstalling it multiple times using different installers, but still no luck.

Does someone know what the problem is?

Maybe remove hoopsnake?


I have the same problem. Trying install and reinstal both rhino 6 or hoopsnake does not work.

anyone have an idea?


If hoopsnake is failing to load, you’ll have to uninstall it.

Or you can put an empty file called Hoopsnake.no6 next to the Hoopsnake.gha file to prevent Rhino6 from loading it. Just make sure it has the same name as the plugin file and the extension .no6

I just installed Hoopsnake. I am using rhino 6.

I don’t understand why none of the example files are working

It Hoopsnake component show
" input parameter D failed to collect data"

Ps: it’s just one component in Hoopsnake right?

Thanks in advance

Probably it was not updated for R6, you can use Anemone instead.

1 Like

Thanks anemone is amazing😍