Rhino 6 Dimension Text Gap


I downloaded Rhino 6 evaluation today and thought I’d give it a spin. Right off the bat, I’m wondering if I’m missing something. I’m looking for the dimension property override to set the text gap distance from the dimension line. In Rhino 5, the “Property Overrides” button has a field for modifying the text gap. In Rhino 6, I can’t find it for the life of me. When I double click on a dimension, the edit linear dimension dialog box does not have the ability to modify the text gap, yet many if not all (haven’t compared yet) of the Rhino 5 property overrides are displayed here. I’ve searched help but that didn’t return any hits. Where did this get moved to?

Another thing that would be a big help, is if the Edit Linear Dimension dialog box were modifiable in size. It’s simply too small as shown below.


(Not sure if the image is going to appear - I’ve uploaded it, but only a link is showing)

When you expand any of the categories at the bottom (Dimension lines, Length units, etc) you have a large amount of items to scroll through in a very small section of the overall dialog box. Either the dialog box should be bigger to start, or it should be modifiable in height so people do not need to scroll through items in what is essentially a tiny window.



Hi Mark,

I just find, that there is a simple way how to move the text from the dimension line. Just get the text (by clicking on the point below the text an move it where you want to).


Hi Mark - got that about the editing control being too constrained. It might be handier, for now, to simply select the dimension and edit via the Properties panel.

Currently text gap is set for the overall annotation style - I do not see a per-object override so far - I’m not sure if that is an oversight or by design, I’ll add it to the pile.




I’m a bit lost on editing the text gap, too. It would be nice to have a setting to adjust globally.

It’d also be nice to select all dimensions, apply a style and be able to edit that style. It may be there already, but I don’t see it.

I’m also new to this. I’m a CNC operator and would like to get involved with this. Just kind of stuck. Lol.

The Text gap property can be changed when editing the annotation style in the Rhino Options dialog (menu: Tools/Options). It’s in the ‘Font’ expander.

If you select multiple dimensions and assign them the same style from the “style” drop down you can then select “Edit Style …” from that same drop down.

Is that what you need?

RH-47289 is fixed in the latest Service Release