Rhino 6 Crash - Grasshopper and other

hello, i’ve been using rhino 6 for a while and yesterday it started crashing when I opened it. It’s happened about 5 times and sometimes happens when i open grasshopper and sometimes just when i open a file or open the program. It was working fine two days ago. i’m worried about working on it in case it crashes as i’m working on my project.

Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Educational, build 2020-02-24
License details: Cloud Zoo. In use by: k ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-23O467M

Hybrid graphics system.
Primary display: Intel® HD Graphics 620 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 950M (NVidia) Memory: 2GB, Driver date: 11-20-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.41

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-20-2019
Driver Version: 26.21.14.4141
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - see if, from the NVidia control panel, you can set the display to ‘high performance’ to force the nvidia card to be used all the time. Does that make a difference? You might also update the Intel driver - the Nvidia one is not so old but you might do that one as well.
It may also help, when getting new drivers, to do clean uninstall/reinstall of both. Please check for drivers on the Nvidia and Intel websites, do not rely on Windows to give accurate information. The Notifications panel in Rhino (Panels menu > Notifications) may have an item that will help you find the right driver - double-click on any driver related messages to see.

Clean uninstall:

-Pascal

high performance was already selected from the nvidia control panel-- i did a clean install from the GeForce experience panel and a clean install from the device manager for the intel one.

just tried opening rhino again and when i launched grasshopper it crashed again

Hello - is the crash only on opening plain grasshopper from inside Rhino, or a particular GH file? Are you getting any crash dump interface to send us the crash information? If so, please send at least one of those in.

-Pascal

plain grasshopper-- i’ve gotten the crash dialogue and sent the reports, is that the crash info you need?

I just updated to the newest rhino 6 build and that didn’t help at all. but, i tried opening gh through rhino 7 and no crashes yet!

tried again-- still crashing! Rhino 7 WIP works fine. uninstalled vray from my machine and this time got this error–

Object: VRayRendererComponent (level 1)
{
Exception has been thrown by the target of an invocation.
TargetInvocationException
}

Object: VRayRendererComponent (level 2)
{
Exception has been thrown by the target of an invocation.
TargetInvocationException
}

Object: VRayRendererComponent (level 3)
{
The type initializer for ‘VRayForGrasshopper.VRayGlobal’ threw an exception.
TypeInitializationException
}

Object: VRayRendererComponent (level 4)
{
Unable to load DLL ‘VRaySDKLibrary’: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
DllNotFoundException
}

Object: VRayLightRigDomeComponent (level 1)
{
Exception has been thrown by the target of an invocation.
TargetInvocationException
}

Object: VRayLightRigDomeComponent (level 2)
{
Exception has been thrown by the target of an invocation.
TargetInvocationException
}

Object: VRayLightRigDomeComponent (level 3)
{
The type initializer for ‘VRayForGrasshopper.VRayGlobal’ threw an exception.
TypeInitializationException
}

Object: VRayLightRigDomeComponent (level 4)
{
Unable to load DLL ‘VRaySDKLibrary’: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
DllNotFoundException
}

thought this was fixed (uninstalled vray, looked to make sure appdata folders were deleted). it worked yesterday (got grasshopper open!), but opened rhino 6 today and it crashed as soon as i opened a file.

So, Rhino starts without problems and when you then open a file (how?) it crashes immediately?
Note - there seems to be another report about this here:


-wim

i opened a file from the splash screen earlier when this happened. just tried again and it worked (i was able to start grasshopper too without any problems). seems like it’s a bit inconsistent in whether it works or not?

From your post in that other thread, I take it everything is fine now?
-wim